Problem at the cosmomc test

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Yo Toda
Posts: 5
Joined: May 18 2020
Affiliation: Department of Cosmosciences, Hokkaido University

Problem at the cosmomc test

Post by Yo Toda » May 18 2020

I downloaded CosmoMC using this command then, I followed PlanckCosmomc readme and used make command. There was no error.
I'm using Centos7, ifort 19.1.0.166 and Python 3.6.8.
Next, I tried quick test, and then got an error

Code: Select all

$ ./cosmomc test.ini
 Number of MPI processes:           1
 file_root:test
 Random seeds:  2395, 12344 rand_inst:   1
 read jla dataset data/Pantheon/full_long.dataset
 reading BAO data set: 6DF
 reading BAO data set: MGS
 reading BAO data set: DR12BAO
 reading WL data set: DES_1YR_final
 Doing non-linear Pk: T
 Doing CMB lensing: T
 Doing non-linear lensing: T
 TT lmax =  2500
 EE lmax =  2500
 ET lmax =  2500
 BB lmax =  2500
 PP lmax =  2500
 lmax_computed_cl  =  2500
 Computing tensors: F
 max_eta_k         =    14000.00    
 transfer kmax     =    10.20000    
 adding parameters for: smicadx12_Dec5_ftl_mv2_ndclpp_p_teb_consext8
 adding parameters for: MGS
 adding parameters for: DR12BAO
 adding parameters for: 6DF
 adding parameters for: JLA
 adding parameters for: BK15_dust
 adding parameters for: DES_1YR_final
 Fast divided into            2  blocks
 Block breaks at:           15
 34 parameters ( 7 slow ( 0 semi-slow), 27 fast ( 0 semi-fast))
 skipped unused params: acib217 xi asz143 aps100 aps143 aps143217 aps217 aksz kgal100 kgal143 kgal143217 kgal217 cal0 cal2
forrtl: severe (174): SIGSEGV, segmentation fault occurred
forrtl: severe (174): SIGSEGV, segmentation fault occurred
If I add -debug

Code: Select all

$ ./cosmomc -debug test.ini
forrtl: severe (59): list-directed I/O syntax error, unit -5, file Internal List-Directed Read
Image              PC                Routine            Line        Source             
cosmomc            000000000069C21B  for__io_return        Unknown  Unknown
cosmomc            00000000006C9E52  for_read_int_lis_     Unknown  Unknown
cosmomc            00000000006C8BD8  for_read_int_lis      Unknown  Unknown
cosmomc            0000000000556CBA  Unknown               Unknown  Unknown
cosmomc            0000000000414722  Unknown               Unknown  Unknown
libc-2.17.so       00007FA2BE10F555  __libc_start_main     Unknown  Unknown
cosmomc            0000000000414629  Unknown               Unknown  Unknown
When I use Cosmomc from https://cosmologist.info/cosmomc/submit.html, I don't get the same error.
However I want to deal with AxionEffectivefluid in my CosmoMC. So I downloaded from github.
Plese help me.
Thank you for your attention and future advise.

Antony Lewis
Posts: 1595
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Problem at the cosmomc test

Post by Antony Lewis » May 19 2020

Not sure what this is. You need to make "cosmomc_debug" to get a debug build. If you have any other ifort versions try them.

Yo Toda
Posts: 5
Joined: May 18 2020
Affiliation: Department of Cosmosciences, Hokkaido University

Re: Problem at the cosmomc test

Post by Yo Toda » May 19 2020

Thanks very much for the reply!
I tried ifort 17.0.8. However, I got the same error.
forrtl: severe (174): SIGSEGV, segmentation fault occurred.

Code: Select all

 ./cosmomc test.ini
 Number of MPI processes:           1
 file_root:test2
 Random seeds:  7735, 10229 rand_inst:   1
 read jla dataset data/Pantheon/full_long.dataset
 reading BAO data set: 6DF
 reading BAO data set: MGS
 reading BAO data set: DR12BAO
 reading WL data set: DES_1YR_final
 Doing non-linear Pk: T
 Doing CMB lensing: T
 Doing non-linear lensing: T
 TT lmax =  2500
 EE lmax =  2500
 ET lmax =  2500
 BB lmax =  2500
 PP lmax =  2500
 lmax_computed_cl  =  2500
 Computing tensors: F
 max_eta_k         =    14000.00    
 transfer kmax     =    10.20000    
 adding parameters for: smicadx12_Dec5_ftl_mv2_ndclpp_p_teb_consext8
 adding parameters for: MGS
 adding parameters for: DR12BAO
 adding parameters for: 6DF
 adding parameters for: JLA
 adding parameters for: BK15_dust
 adding parameters for: DES_1YR_final
 Fast divided into            2  blocks
 Block breaks at:           15
 34 parameters ( 7 slow ( 0 semi-slow), 27 fast ( 0 semi-fast))
 skipped unused params: acib217 xi asz143 aps100 aps143 aps143217 aps217 aksz kgal100 kgal143 kgal143217 kgal217 cal0 cal2
forrtl: severe (174): SIGSEGV, segmentation fault occurred
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Do you have any ideas?

Antony Lewis
Posts: 1595
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Problem at the cosmomc test

Post by Antony Lewis » May 20 2020

Is this running cosmomc_debug? (not a very helpful stack trace..)

Yo Toda
Posts: 5
Joined: May 18 2020
Affiliation: Department of Cosmosciences, Hokkaido University

Re: Problem at the cosmomc test

Post by Yo Toda » May 20 2020

Thank you for the reply.
When I run cosmomc_debug, the same error.

Code: Select all

./cosmomc_debug test.ini
 Number of MPI processes:           1
 file_root:test2
 Random seeds: 19736, 25498 rand_inst:   1
 read jla dataset data/Pantheon/full_long.dataset
 reading BAO data set: 6DF
 reading BAO data set: MGS
 reading BAO data set: DR12BAO
 reading WL data set: DES_1YR_final
 Doing non-linear Pk: T
 Doing CMB lensing: T
 Doing non-linear lensing: T
 TT lmax =  2500
 EE lmax =  2500
 ET lmax =  2500
 BB lmax =  2500
 PP lmax =  2500
 lmax_computed_cl  =  2500
 Computing tensors: F
 max_eta_k         =    14000.00    
 transfer kmax     =    10.20000    
 adding parameters for: smicadx12_Dec5_ftl_mv2_ndclpp_p_teb_consext8
 adding parameters for: MGS
 adding parameters for: DR12BAO
 adding parameters for: 6DF
 adding parameters for: JLA
 adding parameters for: BK15_dust
 adding parameters for: DES_1YR_final
 Fast divided into            2  blocks
 Block breaks at:           15
 34 parameters ( 7 slow ( 0 semi-slow), 27 fast ( 0 semi-fast))
 skipped unused params: acib217 xi asz143 aps100 aps143 aps143217 aps217 aksz kgal100 kgal143 kgal143217 kgal217 cal0 cal2
forrtl: severe (174): SIGSEGV, segmentation fault occurred

Antony Lewis
Posts: 1595
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Problem at the cosmomc test

Post by Antony Lewis » May 20 2020

Not very helpful unfortunately! Sorry I don't know, everything runs fine for me with latest master using ifort 17.0.4 (and gfortran).

Yo Toda
Posts: 5
Joined: May 18 2020
Affiliation: Department of Cosmosciences, Hokkaido University

Re: Problem at the cosmomc test

Post by Yo Toda » May 21 2020

It is unfortunate, but thank you for your advice.

Antony Lewis
Posts: 1595
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Problem at the cosmomc test

Post by Antony Lewis » May 21 2020

If you track down where the error occurs, please post the details.

Antony Lewis
Posts: 1595
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Problem at the cosmomc test

Post by Antony Lewis » May 26 2020

Does it help if you delete "!$OMP PARALLEL DO DEFAULT(shared)" around line 2111 of results.f90? (cf https://github.com/cmbant/CAMB/pull/80)

Yo Toda
Posts: 5
Joined: May 18 2020
Affiliation: Department of Cosmosciences, Hokkaido University

Re: Problem at the cosmomc test

Post by Yo Toda » June 02 2020

Thank you for your very helpful reply!!
I do well, modifying results.f90.

Post Reply