Problem running Cosmomc with simall data

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
María Pía Piccirilli
Posts: 2
Joined: September 18 2019
Affiliation: Facultad de Ciencias Astronómicas y Geofísicas - Universidad Nacional de La Plata

Problem running Cosmomc with simall data

Post by María Pía Piccirilli » September 18 2019

Hello everyone,

I'm having some trouble running the version of July 2019 Cosmomc with Planck likelihood including Simall data. Fast check for likelihood (action=4 in test.ini) runs alright but the run of a test chain with default setting ends up with this error:

clik_init(src/clik.c:77)::ForwardError
clik_lklobject_init(src/clik_helper.c:232)::Error -1111 (Cannot initialize lkl type simall from ./data/clik_14.0/low_l/simall/simall_100x143_offlike5_EE_Aplanck_B.clik/clik dl error : /home/dsy_g/mppg_a/plc-3.0/lib/libclik.so: undefined symbol: clik_simall_init)

If the line that sets low-L EE polarization in the test_planck.ini file is commented, then no trouble arises.
I've checked the links to the data files work fine and that environment variables are correctly settled.

I would really appreciate some hints.
Thank you very much!

Karim Benabed
Posts: 11
Joined: December 18 2008
Affiliation: Institut d'Astrophysique de Paris

Re: Problem running Cosmomc with simall data

Post by Karim Benabed » September 25 2019

Hi

You have probably built PLC using the makefile.
I am sorry but at shipping time, I left an error in the Makefile at line 282. the Makefile lacks the simall source, and thus this part of the likelihood code is not built!
if you replace line 282 which currently reads

Code: Select all

SIMALLLKL :=
by

Code: Select all

SIMALLLKL := $(addprefix $(ODIR)/,clik_simall.o)
you should now be able to use the simall likelihood.

I am sorry for the issue.

María Pía Piccirilli
Posts: 2
Joined: September 18 2019
Affiliation: Facultad de Ciencias Astronómicas y Geofísicas - Universidad Nacional de La Plata

Re: Problem running Cosmomc with simall data

Post by María Pía Piccirilli » September 26 2019

Thank you very much for your reply, Karim!

Indeed, I have built PLC using the makefile provided, so the proposed replacement effectively fixed the problem and cosmomc is running fine.

Thanks a lot for your help! =)

Post Reply