Latest CosmoMC: Unable to install getdist

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Akhilesh Nautiyal(akhi)
Posts: 68
Joined: June 13 2007
Affiliation: Malaviya National Institute of Technology Jaipur

Latest CosmoMC: Unable to install getdist

Post by Akhilesh Nautiyal(akhi) » August 22 2019

Hi,

I am trying to install the latest CosmoMC version. I have successfully complied for cosmomc using

Code: Select all

 make 
in source directory or

Code: Select all

make
in CosmoMC directory but while using

Code: Select all

make all
to install getdist I am having the following error.

Code: Select all

 mkdir -p Release
gfortran -cpp -O3 -ffast-math -ffree-line-length-none -fopenmp -fmax-errors=4 -march=native -DCLIK -I../camb/fortran/Release -I/home/akhilesh/cmbsofts/CosmoMC-July2019/source/../camb/forutils/Release/ -I/home/akhilesh/cmbsofts/planck_2018/code/plc_3.0/plc-3.01/include -JRelease -IRelease/ -c ObjectParamNames.f90 -o Release/ObjectParamNames.o
f951: Warning: Nonexistent include directory ‘../camb/fortran/Release’ [-Wmissing-include-dirs]
f951: Warning: Nonexistent include directory ‘/home/akhilesh/cmbsofts/CosmoMC-July2019/source/../camb/forutils/Release/’ [-Wmissing-include-dirs]
ObjectParamNames.f90:2:8:

     use MpiUtils
        1
Fatal Error: Can't open module file ‘mpiutils.mod’ for reading at (1): No such file or directory
compilation terminated.
make[1]: *** [Makefile:296: Release/ObjectParamNames.o] Error 1
make[1]: Leaving directory '/home/akhilesh/cmbsofts/CosmoMC-July2019/source'
make: *** [Makefile:14: getdist] Error 2   

I tried with both CosmoMC-July as well as CosmoMC-master files.
I will be grateful if someone can help me to resolve this.

Antony Lewis
Posts: 1493
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Latest CosmoMC: Unable to install getdist

Post by Antony Lewis » August 22 2019

You don't need to make GetDist, which is now entirely python (I should remove that option from the Makefile..)

Cosmo Xu
Posts: 7
Joined: March 19 2013
Affiliation: NJU/NAOC

Re: Latest CosmoMC: Unable to install getdist

Post by Cosmo Xu » August 24 2019

Hi there~
just change the default settings for getdist in source/Makefile to the following:

Code: Select all

getdist: directories camb $(DISTFILES)
	$(F90C) -o ../getdist $(DISTFILES) $(LAPACKL) $(GETDISTFLAGS) $(LINKFLAGS)

Post Reply