CosmoMC: seg fault for action=2

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Sunny Vagnozzi
Posts: 51
Joined: August 15 2016
Affiliation: Kavli Institute for Cosmology (KICC), University of Cambridge

Re: CosmoMC: seg fault for action=2

Post by Sunny Vagnozzi » September 26 2019

I also encountered a very similar issue, running with PlanckTTTEEE+lowE and a LCDM+Mnu model. The chains start running for a while, write about 20 points each, and then run into this segfault (I assume it occurs the first time one of the chains explores a region with Mnu<<1 meV). I haven't yet tried the fix Antony suggested but will get around to it soon.

But on a similar note, I also wanted to point out that I had issues with covmats for LCDM+Mnu models. Specifically, in a run with PlanckTTTEEE+lowE and a LCDM+Mnu model, the run starts fine if I use the planck_covmats/base_TTTEEE_lowE_lowl_plikHM.covmat (except that it then crashes due to the segfault discussed in this thread), but if I use planck_covmats/base_mnu_TTTEEE_lowE_lowl_plikHM.covmat (i.e. the same covmat but for the LCDM+Mnu model) the run crashes without even giving the chains the time to write the first points. Anyone encountered anything similar and any ideas as to why it might be happening?

Cheers,
Sunny

Antony Lewis
Posts: 1522
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: CosmoMC: seg fault for action=2

Post by Antony Lewis » September 26 2019

If you can run cosmomc_debug so you can give some details of the crash. Not sure how there could be a problem with the covmat.
I've updated CosmoMC on github with the latest CAMB version.

Sunny Vagnozzi
Posts: 51
Joined: August 15 2016
Affiliation: Kavli Institute for Cosmology (KICC), University of Cambridge

Re: CosmoMC: seg fault for action=2

Post by Sunny Vagnozzi » September 26 2019

Thanks Antony, will try what happens with the new version updated on Github.

On a side note, would you agree that a brute-force approach would be to force the sampler not to explore the region of too low Mnu, i.e. by setting

Code: Select all

param[mnu] = 0.001 3 0.2 0.2 0.2
i.e. setting the lower limit of the prior to be 1 meV instead of 0?

Cheers,
Sunny

Post Reply