CosmoMC: queries

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Rita Sinha
Posts: 3
Joined: September 29 2004
Affiliation: IUCAA, Pune, India

CosmoMC: queries

Post by Rita Sinha » September 29 2004

I have recently started using COSMOMC for carrying out parameter estimation and found it extremely useful and versatile. However, there are few things I am unable to understand and am facing some problems. Kindly give me some suggestions.

1) I would like to do a COSMOMC run with only the WMAP TT data excluding the TE data which as I understand means putting "num_cls" equal to 1. Accordingly I changed the value of "num_cls" (wherever it exists) but it gives an error "MCMC could not start after 1000 tries....." What is going wrong? Am I missing something!

2) I would also like to run COSMOMC but with a scale invariant power spectrum fixing the spectral index, ns (=1). I tried fixing the value in power_tilt.f90 as well as fixing ns parameter values to 1 in 'params.ini' but none of them worked.

3) I would like to change the CAMB part to use my own set of inflationary parameters so as I understand I have to replace the power_tilt.f90 routine with my own routine (primarily the scalar and tensor power parts of it). Which are the other files which need modifications. Also I would like to know where in the CAMB part do you fix (or you vary) the value of scalar to tensor power amplitude. I have read the FAQs and readme sections as well.

Kindly give inputs/suggestions. Thanks.


Rita

Antony Lewis
Posts: 1352
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: COSMOMC queries

Post by Antony Lewis » September 29 2004

1) The easiest way to use only WMAP TT data is to comment out the WMAP_LnLike_TE contribution at the bottom of cmbdata.f90. num_cls=1 probably gives an error with WMAP because at the moment it's not autoamtically removing the TE contribution.

2) To fix ns =1 setting

param8 = 1 1 1 0 0

in the .ini file should do the trick (centre= min=max=1, zero widths)
If this doesn't work, what is the problem?

3) If you just reinterpret the ns, nt, nrun etc parameters as new parameter in your power spectrum file that should be fine. Otherwise you may need to change the global settings for the number of fast parameters, etc.

When running CAMB the ratio of the tensor to scalar power spectrum amplitudes (at 0.05 [tex]h^{-1}[/tex]MPc by default) is set in the initial_ratio(1) parameter. In CosmoMC the ratio is used when adding the scalar and tensor power spectra to get the total.

Post Reply