[CosmoMC] Errors with setting omegach2=0

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Mason Ng
Posts: 26
Joined: May 17 2017
Affiliation: The University of Auckland

[CosmoMC] Errors with setting omegach2=0

Post by Mason Ng » July 13 2017

I'm trying to set omegach2 = 0 for a mini-investigation but I'm getting errors. The output file shows:

Code: Select all

MCMC.f90: Couldn't start after 1000 tries - check starting ranges
application called MPI_Abort(MPI_COMM_WORLD, -922294816) - process 0
In: PMI_Abort(-922294816, application called MPI_Abort(MPI_COMM_WORLD, -922294816) - process 0)
slurmstepd: error: *** STEP 64565924.0 ON compute-e1-020 CANCELLED AT 2017-07-12T19:22:00 ***
srun: Job step aborted: Waiting up to 122 seconds for job step to finish.
srun: error: compute-e1-020: task 0: Killed
srun: error: compute-e1-023: task 1: Killed
srun: error: compute-e1-027: task 3: Killed
srun: error: compute-e1-026: task 2: Killed
In the params.ini file, I made the following changes

Code: Select all

param[omegach2] = 0.0 #yes, fixed
param[omegak] = -0.008 -0.3 0.3 0.001 0.001
CosmoMC seems to be running for omegach2=0.04 at the moment, though I'm hoping to get it to run with omegach2=0. This might be because I should be assigning a prior to more parameters? Please advise, thanks.

Antony Lewis
Posts: 1379
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: [CosmoMC] Errors with setting omegach2=0

Post by Antony Lewis » July 13 2017

I expect for the specified theta values it cannot solve for a value of H0 in the allowed range once you set omch2=0. Make sure you start with parameters that correspond to non-ridiculous H0 and theta values.

Post Reply