CosmoMC not compiling on cluster

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Claudio Nahmad
Posts: 3
Joined: January 14 2017
Affiliation: Facultad de Ciencias UNAM
Contact:

CosmoMC not compiling on cluster

Post by Claudio Nahmad » May 26 2017

Hi All

I am installing cosmomc on a cluster, after succesfull installation of cfitsio, building WMAP data and Planck data (following the steps of 1409.1354v3) I came to the final part of the compilation: building CosmoMC:

- fortran compiler is intel composer XE 2013 , path:

Code: Select allp>

/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort
- openmpi is installed, path of mpif90:

Code: Select allp>

/opt/openmpi/bin/mpif90
I have added both to the PATH (on .bashrc) as follows:

Code: Select allp>

source /opt/apps/compilers/intel/composer_xe_2013_sp1/bin/compilervars.sh intel64
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/openmpi/lib
export PATH=/opt/openmpi/bin:${PATH}
CosmoMC-master/camb/Makefile:

Code: Select allp>

FITSDIR       ?= /home/axel/software/cfitsio/3.4.10
FITSLIB       = /home/axel/software/cfitsio/3.4.10/lib
CosmoMC-master/source/Makefile:

Code: Select allp>

#F90C     = ifort
#Can use this if mpif90 not picking up ifort:
MPIF90C ?= mpif90 -f90=ifort

Code: Select allp>

#set WMAP empty not to compile with WMAP, e.g. WMAP = /scratch/../WMAP9/likelihood_v5
WMAP ?= /home/axel/cosmomc/wmap_likelihood_v5

#Needed for WMAP; set from ~/.bashrc definition or edit here
cfitsio ?= /home/axel/software/cfitsio/3.4.10
When running

Code: Select allp>

make
, the code shows this error:

Code: Select allp>

mkdir -p ReleaseMPI
cd ../camb && \
	make –file=Makefile_main libcamb OUTPUT_DIR=ReleaseMPI \
	RECOMBINATION=recfast EQUATIONS=equations_ppf NONLINEAR=halofit_ppf
make[1]: Entering directory `/home/axel/cosmomc/CosmoMC-master/camb'
mkdir -p ReleaseMPI
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c constants.f90 -o ReleaseMPI/constants.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: constants.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c utils.F90 -o ReleaseMPI/utils.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: utils.F90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c subroutines.f90 -o ReleaseMPI/subroutines.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: subroutines.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c inifile.f90 -o ReleaseMPI/inifile.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: inifile.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c power_tilt.f90 -o ReleaseMPI/power_tilt.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: power_tilt.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c recfast.f90 -o ReleaseMPI/recfast.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: recfast.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c reionization.f90 -o ReleaseMPI/reionization.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: reionization.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c modules.f90 -o ReleaseMPI/modules.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: modules.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c bessels.f90 -o ReleaseMPI/bessels.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: bessels.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c equations_ppf.f90 -o ReleaseMPI/equations_ppf.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: equations_ppf.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c halofit_ppf.f90 -o ReleaseMPI/halofit_ppf.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: halofit_ppf.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c lensing.f90 -o ReleaseMPI/lensing.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: lensing.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c SeparableBispectrum.F90 -o ReleaseMPI/SeparableBispectrum.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: SeparableBispectrum.F90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c cmbmain.f90 -o ReleaseMPI/cmbmain.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: cmbmain.f90: linker input file unused because linking not done
mpif90 -f90=/opt/apps/compilers/intel/composer_xe_2013_sp1.1.106/bin/intel64/ifort -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -module ReleaseMPI -IReleaseMPI/ -c camb.f90 -o ReleaseMPI/camb.o
gfortran: unrecognized option '-no-prec-div'
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: language Host not recognized
gfortran: ReleaseMPI: linker input file unused because linking not done
gfortran: camb.f90: linker input file unused because linking not done
ar -r ReleaseMPI/libcamb_recfast.a ReleaseMPI/constants.o  ReleaseMPI/utils.o   ReleaseMPI/subroutines.o ReleaseMPI/inifile.o  ReleaseMPI/power_tilt.o  ReleaseMPI/recfast.o ReleaseMPI/reionization.o ReleaseMPI/modules.o ReleaseMPI/bessels.o ReleaseMPI/equations_ppf.o ReleaseMPI/halofit_ppf.o ReleaseMPI/lensing.o ReleaseMPI/SeparableBispectrum.o ReleaseMPI/cmbmain.o ReleaseMPI/camb.o
ar: creating ReleaseMPI/libcamb_recfast.a
ar: ReleaseMPI/constants.o: No such file or directory
make[1]: *** [ReleaseMPI/libcamb_recfast.a] Error 1
make[1]: Leaving directory `/home/axel/cosmomc/CosmoMC-master/camb'
make: *** [camb] Error 2
I have followed instructions on this thread: http://cosmocoffee.info/viewtopic.php?t ... eb6855d71a changing my fortran compiler flag several times, trying to make the code run ifort instead of gfortran, nothing has helped.

I have built CosmoMC in three different computers: two macs and one linux (ubuntu) machine, this error had never appeared before, i'm thinking it might have something to do with trying to do it in a cluster.

Any help will be apreciated, thank you in advance.

-Claudio Nahmad

Antony Lewis
Posts: 1353
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: CosmoMC not compiling on cluster

Post by Antony Lewis » May 26 2017

I'd ask the cluster admin folk for help with getting mpif90 to run ifort. Maybe they have a different command.

Post Reply