CAMB error with w=1/3

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Omar Ruiz Macias
Posts: 10
Joined: February 15 2014
Affiliation: Cinvestav

CAMB error with w=1/3

Post by Omar Ruiz Macias » September 03 2016

Hi everyone,

I installed last version of CAMB (May 2016) and I just found that the code breaks using w=1/3, being w the constant in the state equation. It works perfectly from w=-3 to w=0.24.

Any idea of what might be happening?

The output for w=1/3 is as follows:

omar@sci-hi ~/codigos/CAMB-May2016 $ ./camb params.ini
forrtl: error (73): floating divide by zero
Image PC Routine Line Source
camb 00000000005478F5 Unknown Unknown Unknown
camb 0000000000545517 Unknown Unknown Unknown
camb 00000000004E63F4 Unknown Unknown Unknown
camb 00000000004E6206 Unknown Unknown Unknown
camb 000000000049D686 Unknown Unknown Unknown
camb 00000000004A1A76 Unknown Unknown Unknown
camb 0000000000562740 Unknown Unknown Unknown
camb 000000000053D72D Unknown Unknown Unknown
camb 000000000053CAAF Unknown Unknown Unknown
camb 000000000052E1FB Unknown Unknown Unknown
camb 000000000052E1A7 Unknown Unknown Unknown
camb 00000000004859D2 modelparams_mp_de 529 modules.f90
camb 00000000004157DF modelparams_mp_ca 393 modules.f90
camb 00000000004140B0 camb_mp_camb_getr 136 camb.f90
camb 00000000004028F0 MAIN__ 321 inidriver.F90
camb 00000000004009CE Unknown Unknown Unknown
camb 0000000000562E76 Unknown Unknown Unknown
camb 000000000056306A Unknown Unknown Unknown
camb 00000000004008A9 Unknown Unknown Unknown
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
camb 00000000004A1B96 Unknown Unknown Unknown
camb 0000000000562740 Unknown Unknown Unknown
camb 0000000000570FC6 Unknown Unknown Unknown
camb 00000000004A1B4E Unknown Unknown Unknown
camb 0000000000562740 Unknown Unknown Unknown
camb 000000000053D72D Unknown Unknown Unknown
camb 000000000053CAAF Unknown Unknown Unknown
camb 000000000052E1FB Unknown Unknown Unknown
camb 000000000052E1A7 Unknown Unknown Unknown
camb 00000000004859D2 modelparams_mp_de 529 modules.f90
camb 00000000004157DF modelparams_mp_ca 393 modules.f90
camb 00000000004140B0 camb_mp_camb_getr 136 camb.f90
camb 00000000004028F0 MAIN__ 321 inidriver.F90
camb 00000000004009CE Unknown Unknown Unknown
camb 0000000000562E76 Unknown Unknown Unknown
camb 000000000056306A Unknown Unknown Unknown
camb 00000000004008A9 Unknown Unknown Unknown

Best regards.

Antony Lewis
Posts: 1352
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: CAMB error with w=1/3

Post by Antony Lewis » October 20 2016

It probably does assume w<1/3 in various places if it is being described as dark energy.

Post Reply