cosmomc: Reionization_zreFromOptDepth: Did not converge to optical depth

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Lung-Yih Chiang
Posts: 1
Joined: April 12 2008
Affiliation: ASIAA

cosmomc: Reionization_zreFromOptDepth: Did not converge to o

Post by Lung-Yih Chiang » July 31 2008

I am running cosmomc to fit a non-WMAP power spectrum where the first acoustic peaks is quite low. Since it's not WMAP-generic power spectrum, I use

#n_s
param8 = 1.05 0.5 1.5 0.02 0.01
#log[10^10 A_s]
param11 = 3. 2. 4. 0.01 0.01

among other parameters.

I have used sampling method=4, but I keep getting the following message such as :

Reionization_zreFromOptDepth: Did not converge to optical depth
tau = 0.280901184587097 optical_depth = 0.310809463262558
40.0000000000000 39.9987792968750

Can anyone help on this issue? Thanks a lot!

Antony Lewis
Posts: 1501
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: cosmomc: Reionization_zreFromOptDepth: Did not converge

Post by Antony Lewis » July 31 2008

Probably you are getting into very high \tau values out of the assumed prior range of the reionization module. Try editing it to allow for z_re > 40, or use a tighter prior on \tau.

Cassio Pigozzo
Posts: 4
Joined: June 17 2015
Affiliation: Federal University of Bahia / Imperial College London

cosmomc: Reionization_zreFromOptDepth: Did not converge to o

Post by Cassio Pigozzo » July 21 2015

Dear Antony Lewis,

I just installed and compiled the new version of cosmoMC (jul2015). Just to check if it's working good, without changing any parameter or model or propose, I asked to run the file test.ini (as it comes when downloaded), just choosing action 0. After a couple of hours building the chains, I got this same error:

Reionization_zreFromOptDepth: Did not converge to optical depth
tau = 0.40126390858257543 optical_depth = 0.43751390948217950
50.000000000000000 49.998474121093750

I'm using gfortran 6 (experimental) on OS X 10.10.4.
Thanks.

Cheers,
Cassio

Jason Dossett
Posts: 97
Joined: March 19 2010
Affiliation: The University of Texas at Dallas
Contact:

cosmomc: Reionization_zreFromOptDepth: Did not converge to o

Post by Jason Dossett » July 21 2015

Try setting the flag: stop_on_error = F.

This will allow the program to keep running and reject that particular sample. You are just going into a bad area of the parameter space. This should keep the chains running. You will still see that error but the runs wont stop

Danylo Yakymiv
Posts: 4
Joined: July 27 2015
Affiliation: Stony Brook

cosmomc: Reionization_zreFromOptDepth: Did not converge to o

Post by Danylo Yakymiv » July 30 2015

Hello,

I am consistently having the above issue with a run using BAO and lensing datasets. The stop_on_error flag is set to F, but the error still stops the chains. I see a use_min_zre = 0 parameter set in common.ini, but nothing constraining it below 40. I am also unable to find a prior on [tex]\tau[/tex] in any of the files used for this run. Any help would be greatly appreciated.

Antony Lewis
Posts: 1501
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: cosmomc: Reionization_zreFromOptDepth: Did not converge

Post by Antony Lewis » July 30 2015

I would just fix tau as it is unconstrained - as in batch2/lensonly.ini.

Danylo Yakymiv
Posts: 4
Joined: July 27 2015
Affiliation: Stony Brook

cosmomc: Reionization_zreFromOptDepth: Did not converge to o

Post by Danylo Yakymiv » August 06 2015

This solved the issue, thank you!

Post Reply