Trouble running GetDistGUI.py

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Richard Hall
Posts: 1
Joined: August 02 2017
Affiliation: Cambridge University

Trouble running GetDistGUI.py

Post by Richard Hall » August 02 2017

Hi I've recently installed GetDist to plot distributions from a MCMC script I use.

I'm trying to run the GetDistGUI.py but am getting this error message:

Code: Select all

Could not find getdist.gui.mainwindow: configure your PYTHONPATH as described in the readme!
In the readme it doesn't mention anything about PYTHONPATH (not that I can see), any ideas?

I'm running MacOSX 10.12.5, python 2.7.11, I have installed all the relevant dependencies with pip, I can run the setup.py file in the GetDist directory and all the tests pass.

Thanks!

Antony Lewis
Posts: 1379
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Trouble running GetDistGUI.py

Post by Antony Lewis » August 02 2017

The error is when getdist is not in your path (e.g. "import getdist" will fails). You installed using pip, or ran setup.py install, the path should be fine. If installed from git, then need to include the relevant path in PYTHONPATH.

The error might also come from some other missing import, also check the final exception message.

Emma Clarke
Posts: 1
Joined: July 25 2018
Affiliation: University of New Hampshire

Re: Trouble running GetDistGUI.py

Post by Emma Clarke » August 02 2018

I am having a similar problem when trying to run GetDistGUI.py. My PYTHONPATH is configured and a couple weeks ago everything worked fine, but now I get the following errors after running >python python/GetDistGUI.py:

Could not find getdist.gui.mainwindow: configure your PYTHONPATH as described in the readme!
Traceback (most recent call last):
File "python/GetDistGUI.py", line 16, in <module>
from getdist.gui.mainwindow import MainWindow
File "/Users/emma/CosmoMC/python/getdist/gui/mainwindow.py", line 18, in <module>
from getdist.gui import SyntaxHighlight
File "/Users/emma/CosmoMC/python/getdist/gui/SyntaxHighlight.py", line 3, in <module>
from PySide.QtCore import QRegExp
ImportError: No module named PySide.QtCore

Any idea what I can try fixing?

Antony Lewis
Posts: 1379
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Trouble running GetDistGUI.py

Post by Antony Lewis » August 03 2018

This actually looks like an issue with your PySide installation.

Post Reply