Errors when making cosmomc

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Albin Nilsson
Posts: 13
Joined: October 05 2016
Affiliation: NCBJ, Warsaw

Errors when making cosmomc

Post by Albin Nilsson » December 20 2016

I'm installing cosmomc on our cluster, and here's an error I have been unable to solve.
I can install the Planck PLC with no trouble, but when I try to make cosmomc it throws me the following (I am using ifort and mpif90 with the ifort flag).
I tried a global search for the missing files in order to link them in manually, but cannot find them anywhere.
Any ideas are welcome, thanks in advance!

Code: Select allp>

mpif90 -f90=ifort -o ../cosmomc ReleaseMPI/MiscUtils.o ReleaseMPI/ArrayUtils.o ReleaseMPI/StringUtils.o ReleaseMPI/MpiUtils.o ReleaseMPI/FileUtils.o ReleaseMPI/RandUtils.o ReleaseMPI/ObjectLists.o ReleaseMPI/Interpolation.o ReleaseMPI/IniObjects.o ReleaseMPI/ObjectParamNames.o ReleaseMPI/Matrix_utils_new.o  ReleaseMPI/settings.o ReleaseMPI/samples.o ReleaseMPI/IO.o ReleaseMPI/likelihood.o ReleaseMPI/GeneralTypes.o ReleaseMPI/BaseParameters.o ReleaseMPI/propose.o ReleaseMPI/ParamSet.o ReleaseMPI/PowellConstrainedMinimize.o ReleaseMPI/ImportanceSampling.o ReleaseMPI/MCMC.o ReleaseMPI/minimize.o ReleaseMPI/SampleCollector.o ReleaseMPI/GeneralSetup.o ReleaseMPI/CosmologyTypes.o ReleaseMPI/CosmoTheory.o ReleaseMPI/bbn.o ReleaseMPI/Calculator_Cosmology.o ReleaseMPI/CalcLike_Cosmology.o ReleaseMPI/Likelihood_Cosmology.o ReleaseMPI/Calculator_CAMB.o ReleaseMPI/CMB_BK_Planck.o ReleaseMPI/cliklike.o ReleaseMPI/mpk.o ReleaseMPI/wigglez.o ReleaseMPI/bao.o ReleaseMPI/supernovae_Union2.o ReleaseMPI/supernovae_SNLS.o ReleaseMPI/supernovae_JLA.o ReleaseMPI/szcounts.o ReleaseMPI/supernovae.o ReleaseMPI/HST.o  ReleaseMPI/CMB.o ReleaseMPI/CMBlikes.o ReleaseMPI/ElementAbundances.o ReleaseMPI/wl.o ReleaseMPI/CosmologyParameterizations.o ReleaseMPI/DataLikelihoods.o ReleaseMPI/calclike.o ReleaseMPI/CosmologyConfig.o ReleaseMPI/driver.o -L../camb/ReleaseMPI -lcamb_recfast    -L/mnt/opt/groups/app-qcosmo/cosmomc/planckdata_and_plc/plc−2.0/lib -lclik_f90 -mkl -O3 -no-prec-div -fpp -openmp -xHost -DMPI -DCLIK -I../camb/ReleaseMPI -I/mnt/opt/groups/app-qcosmo/cosmomc/planckdata_and_plc/plc−2.0/include -module ReleaseMPI -IReleaseMPI/
ld: warning: libibmad.so.5, needed by /mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpichf90.so, not found (try using -rpath or -rpath-link)
ld: warning: librdmacm.so.1, needed by /mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpichf90.so, not found (try using -rpath or -rpath-link)
ld: warning: libibumad.so.3, needed by /mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpichf90.so, not found (try using -rpath or -rpath-link)
ld: warning: libibverbs.so.1, needed by /mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpichf90.so, not found (try using -rpath or -rpath-link)
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `mad_get_field@IBMAD_1.3'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `ibv_modify_qp@IBVERBS_1.1'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `umad_release_ca@IBUMAD_1.0'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `umad_register@IBUMAD_1.0'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `rdma_disconnect@RDMACM_1.0'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `ibv_create_qp@IBVERBS_1.1'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `ibv_destroy_qp@IBVERBS_1.1'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `umad_open_port@IBUMAD_1.0'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `ibv_destroy_ah@IBVERBS_1.1'
/mnt/opt/tools/slc6/mvapich2/1.9a/lib/libmpich.so: undefined reference to `ibv_reg_xrc_rcv_qp@IBVERBS_1.1'

Jason Dossett
Posts: 97
Joined: March 19 2010
Affiliation: The University of Texas at Dallas
Contact:

Errors when making cosmomc

Post by Jason Dossett » December 22 2016

Just out of curiousity, it appears you have intel compilers installed. Do you know if you have the cluster version of the compilers? If so, you could try mpiifort and build with intel's mpi interface.

It looks like the version of mpich which you are using was compiled with a need for some infiniband related libraries that for some reason your system is now unable to find.

You can try running the following command and see if you get anything. Since I dont know what system you are on I am not positive it will work, but you can give it a try.

Code: Select allp>

ldconfig -p | grep libibmad

Post Reply