CosmoMC: symbol lookup error

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Ana Vasile
Posts: 25
Joined: March 26 2006
Affiliation: Institute for Space Sciences
Contact:

CosmoMC: symbol lookup error

Post by Ana Vasile » April 12 2006

Hello!

I am back again with a question.
When running cosmomc on Scientific Linux (with intel fortran 9.0) one of the first errors I got was:

./cosmomc: symbol lookup error: ./cosmomc: undefined symbol: _intel_fast_memset

I've solved it by adding (as root) the path to the bin directory in fortran (e.g. /opt/intel/fc/9.0/bin) to ld.so.conf and then running ldconfig

Now I am trying to run cosmomc on a cluster which has Rocksclusters (a Red Hat Enterprise 3 flavor) and again, the same error, but this time I don't have root.
Do you have any ideeas how to solve this without root rights?

Thank you,

Ana

P.S. The "error" messages from my previous topic are gone in the new version of cosmomc!

David Larson
Posts: 11
Joined: September 25 2004
Affiliation: Johns Hopkins University

CosmoMC: symbol lookup error

Post by David Larson » May 03 2006

I just ran into this problem myself (with some code I wrote, not cosmomc). I've solved it by setting LD_LIBRARY_PATH environmental variable to point to the location of the .so files that I need. Since I'm using bash, I have the following line in my .bashrc file:

export LD_LIBRARY_PATH=/opt/intel/mkl/8.0.2/lib/32:/opt/intel/fc/9.0/lib:/usr/lib:/usr/local/lib

I don't know if this will help. I may have a nonstandard install of ifort, since intel provides .rpm files and I'm running a debian-based linux system.

Ana Vasile
Posts: 25
Joined: March 26 2006
Affiliation: Institute for Space Sciences
Contact:

CosmoMC: symbol lookup error

Post by Ana Vasile » May 04 2006

Thank you very much David for your help, it worked!!!

Post Reply