cosmomc: "segmentation fault.." error

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Ana Vasile
Posts: 25
Joined: March 26 2006
Affiliation: Institute for Space Sciences
Contact:

cosmomc: \"segmentation fault..\" error

Post by Ana Vasile » March 31 2006

Hi!

I've run ./cosmomc with the original params.ini file (just changing to 15000 steps and use_HST = F, use_Age_Tophat_Prior = F) and it crashed.
This is the last output on the shell:

0 rat: 0.3719803 in 11963 (M) best: 5626.176

and this is the error message:

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
ld-linux.so.2 0040B7A2 Unknown Unknown Unknown
libguide.so 00131444 Unknown Unknown Unknown
libpthread.so.0 0014B341 Unknown Unknown Unknown
libc.so.6 004EB6FE Unknown Unknown Unknown

Let me add some details that could be useful:

I am running the code on a Dual Athlon 1800+ , 1GB RAM. It has Scientific Linux 4.2 on it.
To build cosmomc I've used ifort 9.0 with mkl 8.02 (cfitsio3006).

Could someone please tell me what is wrong?

Thank you,

Ana

Antony Lewis
Posts: 1495
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: cosmomc: \\\"segmentation fault..\\\" error

Post by Antony Lewis » March 31 2006

If your run has basically completed, the error is probably harmless - just a problem with closing down. The chains are probably fine?

You sometimes get messages like this if the process is terminated because you've reached a run time limit on the computer.

Ana Vasile
Posts: 25
Joined: March 26 2006
Affiliation: Institute for Space Sciences
Contact:

cosmomc: \"segmentation fault..\" error

Post by Ana Vasile » March 31 2006

Yes, you are right, the chains are ok! I didn't even check this since I belived the program had crashed.

Thanks a lot!

Pascal Vaudrevange
Posts: 50
Joined: March 26 2006
Affiliation: DESY
Contact:

cosmomc: \"segmentation fault..\" error

Post by Pascal Vaudrevange » April 06 2006

I heard that ifort9.0 is known to produce wrong results with some codes - but I don't know whether CosmoMC compiles correctly with it. Maybe you should switch back to ifort8.1..

Post Reply