Help instaling CAMB

Use of Cobaya. camb, CLASS, cosmomc, compilers, etc.
Post Reply
Clara Rojas
Posts: 15
Joined: May 11 2005
Affiliation: Yachay TECH University

Help instaling CAMB

Post by Clara Rojas » February 22 2023

Hi again,

I upgrade python and camb stop working, then I remove to reinstall and I can't.

I obtained the following message:

Running setup.py install for camb ... error
error: subprocess-exited-with-error

× Running setup.py install for camb did not run successfully.
│ exit code: 1
╰─> [6 lines of output]
running install
/opt/homebrew/lib/python3.9/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
warnings.warn(
running build
running build_py
error: Build failed - you must have "make" installed. E.g. on ubuntu install with "sudo apt install make" (or use build-essential package).
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> camb

I appreciate your help. I am using an Imac with the operative system Ventura

Antony Lewis
Posts: 1930
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Help instaling CAMB

Post by Antony Lewis » February 22 2023

Did you try the suggestion in the error message about make?

You could also install the binary from conda instead.

Clara Rojas
Posts: 15
Joined: May 11 2005
Affiliation: Yachay TECH University

Re: Help instaling CAMB

Post by Clara Rojas » February 22 2023

Thanks for your help!

I didn't have the command line installed.


Best Regards,
Clara

Post Reply