Cobaya: not generating any data when using polychord

Use of Cobaya. camb, CLASS, cosmomc, compilers, etc.
Post Reply
Jiwon Park
Posts: 9
Joined: July 09 2019
Affiliation: Soongsil University

Cobaya: not generating any data when using polychord

Post by Jiwon Park » September 22 2022

Dear all,

I'm using cobaya and polychord to verify my modified CAMB code. However, it doesn't generate any data(raw points, live points, etc.) even after running for a few days on a local server using 48 CPUs. It keeps throwing the following message:

TTanhReionization_zreFromOptDepth: Did not converge to optical depth
tau = 0.68200043554722278 optical_depth = 0.69826116316660436
50.000000000000000 49.993896484375000
(If running a chain, have you put a constraint on tau?)

However, I have indeed put a constraint on tau using cobaya-cosmo-generator as follows:

tau:
prior:
min: 0.01
max: 0.8
ref:
dist: norm
loc: 0.055
scale: 0.006
proposal: 0.003
latex: \tau_\mathrm{reio}

I've checked that the modified CAMB code runs with no problem with sensible ranges of physical parameters, and cobaya also runs safely with the standard mcmc(with fast-dragging) sampler. But I want to use polychord since I suspect that my model might have some multi-modal distributions. Is this a normal situation, so do I have to wait more days? Or should I change the constraints of some of the parameters, maybe tau?

Any comments or help would be appreciated. Thank you in advance.

Jiwon Park

Antony Lewis
Posts: 1842
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Cobaya: not generating any data when using polychord

Post by Antony Lewis » September 23 2022

You have a linear prior, which is not really a constraint over that range. Usually people use the Planck LowL EE, or at least a Gaussian prior.

Post Reply