Planck code: error in configure

Use of Cobaya. camb, CLASS, cosmomc, compilers, etc.
Post Reply
qile zhang
Posts: 1
Joined: July 11 2022
Affiliation: Shanghai Normal University

Planck code: error in configure

Post by qile zhang » July 31 2022

hi, I am a new Mac M1 user, I have a problem compiling the plc-3.1 now, when i run "./waf configure", It seems that a problem in "Checking for library dl", so has anyone encountered this problem? Is this the problem of arm architecture?

Code: Select all

Checking for program 'gfortran, g77'                       : /Users/marsh/Anaconda/anaconda3/bin/arm64-apple-darwin20.0.0-gfortran
Checking for program 'ar'                                  : arm64-apple-darwin20.0.0-ar
Check gfortran version                                     : not found, let's hope for the best...
Compile a test code with gfortran                          : yes
retrieve gfortran link line                                : ok
gfortran link line                                         : -L/Users/marsh/Anaconda/anaconda3/lib -lgfortran -lgomp
Setting install root to                                    : /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1
Setting install bin directory to                           : /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1/bin
Setting install lib directory to                           : /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1/lib
Setting install include directory to                       : /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1/include
Checking for program 'python'                              : /Users/marsh/Anaconda/anaconda3/bin/python
Checking for python version                                : 3.9.13
python-config                                              : /Users/marsh/Anaconda/anaconda3/bin/python3.9-config
Asking python-config for pyembed '--cflags --libs --ldflags --embed' flags : yes
Testing pyembed configuration                                              : Could not build a python embedded interpreter
No suitable python distribution found
Cause : 'The configuration failed
(complete log in /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1/build/config.log)'
Compilation will continue without it (but I strongly advise that you install it)
Checking for library dl                                                    : not found
The configuration failed
(complete log in /Users/marsh/CosmoMC/code/plc_3.0/plc-3.1/build/config.log)

Post Reply