CosmoMC run error, pmc-config not found

Use of Cobaya. camb, CLASS, cosmomc, compilers, etc.
Post Reply
Trupti Vijay Patil
Posts: 7
Joined: January 08 2021
Affiliation: PG

CosmoMC run error, pmc-config not found

Post by Trupti Vijay Patil » January 27 2021

I am trying to install CosmoMC as per: https://arxiv.org/pdf/1808.05080.pdf (A Guide for CosmoMC Installation and Running)
I am trying very hard to make it successful. I worked out all the steps properly. CAMB and MCMC all are running fine. No problem at all. But while running CosmoMC with "ryzen@ryzen-System-Product-Name:~/CosmoMC$ mpirun -np 5 ./cosmomc test.ini" after editing test.ini file it shows some errors.
So, now I am trying to reinstall PLC-3.01. During this process after running "./ waf configure -- install_all_deps" command I see two errors as "Checking for program 'pmc-config' : not found
Checking for library pmc : not found " I attempted many times to resolve these errors but no luck. Also, PMC waf configuration is not taking GSL path even if it is already installed. So basically errors are getting piled up. I am literally clueless now how to proceed further and resolve these issues.
I am very uncertain about whether it is a hardware issue or something. CPU details are also attached along with error screenshots.
Can anyone help me out with this. Any kind of assistance is very much appreciated.
Thank you in advance.
Attachments
Screenshot from 2021-01-13 17-00-55.png
Screenshot from 2021-01-13 17-00-55.png (245.36 KiB) Viewed 192 times

Antony Lewis
Posts: 1686
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: CosmoMC run error, pmc-config not found

Post by Antony Lewis » February 02 2021

I don't know, but check "mpirun" is set up to use the correct compiler.

Post Reply