CosmoMC: Compiling with PGI compiler

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
gongbo zhao
Posts: 69
Joined: January 04 2005
Affiliation: ICG, Portsmouth
Contact:

CosmoMC: Compiling with PGI compiler

Post by gongbo zhao » September 01 2005

Dear all:
I am now switching to a new supercomputer (much more powerful) to run CosmoMC . I run 4 chains on 4 nodes (MPI)and use 4 CPUs to run one chain on one node (openmp). The PGI fortran compiler is installed in this machine. I have modified the Makefiles as follows:
1) Makefile in /CAMB :
F90C = pgf90
FFLAGS = -mp -fastsse
2) Makefile in /source :
F90C = /opt/mpich-1.2.5/gm_pgi/bin/mpif90
LAPACKL = -L/opt/pgi/linux86-64/5.1/lib -llapack -lacml -lblas
INCLUDE = -I../camb
FFLAGS = -mp -fastsse -DMPI


Then CosmoMC is successfully compiled and run correctly using SN only . However , when other datasets are added , such as WMAP and SDSS ,etc. CosmoMC doesn't work . It seems in this case CAMB doesn't generate right Cls . I am puzzled and wonder whether CosmoMC can access and call CAMB correctly in this case. Any suggestions and comments on that ?
Thanks in advance.

Best,
Gongbo Zhao

gongbo zhao
Posts: 69
Joined: January 04 2005
Affiliation: ICG, Portsmouth
Contact:

CosmoMC: Compiling with PGI compiler

Post by gongbo zhao » September 02 2005

Dear all:
The above problem can be solved by changing Makefile of CAMB :

F90C = pgf90
FFLAGS = -mp -fastsse

to :

F90C = pgf90
FFLAGS = -mp -fast

CosmoMC can run and generate correct chain files .(.txt) . But problems arise when getdist . There are no output files and the getdist stops after reading the chain files . I guess the reason stems from the Makefile in /source . Some parameters must be wrong . I am not quite familiar with the PGI complier (Portland f90) . Anybody can give me some suggestions ? Thanks a lot.

Best,
Gongbo Zhao

Post Reply