issues compiling CosmoMC and CAMB

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Elizabeth Gould
Posts: 12
Joined: January 30 2015
Affiliation: Queen's University

issues compiling CosmoMC and CAMB

Post by Elizabeth Gould » February 10 2020

When using the October 2019 version of CosmoMC, when I run the makefile, I get

Code: Select all

[egould@gra-login2 cmc003]$ make
cd ./source && make cosmomc BUILD=MPI
make[1]: Entering directory '/home/egould/CosmoMC/cmc003/source'
mkdir -p ReleaseMPI
cd ../camb/fortran && \
make --file=Makefile_main libcamb OUTPUT_DIR=ReleaseMPI \
    FORUTILSPATH=/home/egould/CosmoMC/cmc003/source/../camb/forutils
make[2]: Entering directory '/home/egould/CosmoMC/cmc003/camb/fortran'
make[3]: *** No rule to make target 'ReleaseMPI'.  Stop.
make[2]: *** [Makefile_main:144: libforutils] Error 2
make[2]: Leaving directory '/home/egould/CosmoMC/cmc003/camb/fortran'
make[1]: *** [Makefile:315: camb] Error 2
make[1]: Leaving directory '/home/egould/CosmoMC/cmc003/source'
make: *** [Makefile:17: cosmomc] Error 2
For CAMB, this is

Code: Select all

[egould@gra-login2 fortran]$ make
make[1]: *** No rule to make target 'Release'.  Stop.
make: *** [Makefile_main:144: libforutils] Error 2
I have checked that this does not happen for the case of the older version of CosmoMC I have used in the past.

Antony Lewis
Posts: 1543
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: issues compiling CosmoMC and CAMB

Post by Antony Lewis » February 11 2020

Did you do a recursive clone from github? (you should)

Post Reply