The DES astro parameterization

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Weikang Lin
Posts: 6
Joined: May 04 2016
Affiliation: North Carolina State University

The DES astro parameterization

Post by Weikang Lin » February 08 2020

Hi everyone,

I try the switch the parameterization in CosmoMC to astro by including DEFAULT(batch3/DES_astro_priors.ini). But errors show as below, any ideas?
orrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
cosmomc 00000000006F2AD3 for__signal_handl Unknown Unknown
libpthread-2.17.s 00002B766A1725D0 Unknown Unknown Unknown
cosmomc 000000000062C606 Unknown Unknown Unknown
cosmomc 000000000068C805 Unknown Unknown Unknown
cosmomc 00000000005E8F6D Unknown Unknown Unknown
cosmomc 00000000005E9D3C Unknown Unknown Unknown
libiomp5.so 00002B7668FB0C53 __kmp_invoke_micr Unknown Unknown
libiomp5.so 00002B7668F807ED __kmp_fork_call Unknown Unknown
libiomp5.so 00002B7668F57E2A __kmpc_fork_call Unknown Unknown
cosmomc 00000000005E9A0E Unknown Unknown Unknown
cosmomc 0000000000546087 Unknown Unknown Unknown
cosmomc 00000000005443E1 Unknown Unknown Unknown
cosmomc 0000000000494E91 Unknown Unknown Unknown
cosmomc 00000000005564A3 Unknown Unknown Unknown
cosmomc 00000000005555AB Unknown Unknown Unknown
cosmomc 0000000000553189 Unknown Unknown Unknown
cosmomc 0000000000485A7C Unknown Unknown Unknown
cosmomc 000000000055EE0A Unknown Unknown Unknown
cosmomc 0000000000413F62 Unknown Unknown Unknown
libc-2.17.so 00002B766A3A13D5 __libc_start_main Unknown Unknown
cosmomc 0000000000413E69 Unknown Unknown Unknown

Antony Lewis
Posts: 1633
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: The DES astro parameterization

Post by Antony Lewis » February 10 2020

make and run cosmomc_debug to maybe get a more helpful error trace.

Weikang Lin
Posts: 6
Joined: May 04 2016
Affiliation: North Carolina State University

Re: The DES astro parameterization

Post by Weikang Lin » February 26 2020

Antony Lewis wrote:
February 10 2020
make and run cosmomc_debug to maybe get a more helpful error trace.
Thank you Antony. Sorry for the late response. I ran cosmomc_debug but got the same error message.

Antony Lewis
Posts: 1633
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: The DES astro parameterization

Post by Antony Lewis » February 27 2020

No useful stack trace?

Weikang Lin
Posts: 6
Joined: May 04 2016
Affiliation: North Carolina State University

Re: The DES astro parameterization

Post by Weikang Lin » March 11 2020

Antony Lewis wrote:
February 27 2020
No useful stack trace?
After I ran CosmoMC_debug test.ini with DEFAULT(batch3/DES_astro_priors.ini), I got:

Code: Select all

forrtl: severe (408): fort: (7): Attempt to use pointer DARKENERGY when it is not associated with a target
. I was running with the DES likelihoods.

Antony Lewis
Posts: 1633
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: The DES astro parameterization

Post by Antony Lewis » March 11 2020

Interesting, no stack trace? In recent CAMB versions DarkEnergy is an allocatable not a pointer, so not exactly sure where that is coming from, but may just be an inaccurate error message.

It should be allocated in subroutine CAMBCalc_InitCAMBParams(this,P)
.

Levon Pogosian
Posts: 25
Joined: September 25 2004
Affiliation: Simon Fraser University
Contact:

Re: The DES astro parameterization

Post by Levon Pogosian » April 06 2020

Hi Weikang and Antony,
Just wondering if you managed to find a fix to this problem and would be happy to share it. I am having the same issue.
Thanks,
levon

Antony Lewis
Posts: 1633
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: The DES astro parameterization

Post by Antony Lewis » April 06 2020

Try adding

Code: Select all

this%CurrentState => Info%State
after this line: https://github.com/cmbant/CosmoMC/blob/master/source/Calculator_CAMB.f90#L217

? (with the default parameterization this is already done in CMBtoCAMB)

Levon Pogosian
Posts: 25
Joined: September 25 2004
Affiliation: Simon Fraser University
Contact:

Re: The DES astro parameterization

Post by Levon Pogosian » April 14 2020

Thanks a lot, Antony. The error message I was getting before disappeared after your fix and it seems to be running OK (i will find out if I didn't make other silly mistakes after the job finishes on the cluster). All the best. Levon

Post Reply