LowTEB likelihood problem

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Esteban Chalbaud
Posts: 11
Joined: June 01 2019
Affiliation: Master's student

LowTEB likelihood problem

Post by Esteban Chalbaud » August 11 2019

I am getting this from bflike likelihood, apparently gfortran cannot read the .ini file:

forrtl: severe (257): formatted I/O to unit open for unformatted transfers, unit 42, file /cephfs/scratch/11068066/plc_3.0/low_l/bflike/
Image PC Routine Line Source
cosmomc 00000000006ABCFE for__io_return Unknown Unknown
libifcoremt.so.5 0000152AED89370B for_read_seq_nml Unknown Unknown
libclik.so 0000152AF02B7B75 bflike_smw_mp_ini Unknown Unknown
libclik.so 0000152AF0276193 bflike_smw_extra_ Unknown Unknown
libclik.so 0000152AF024FFE6 clik_bflike_smw_i Unknown Unknown
libclik.so 0000152AF021846B clik_lklobject_in Unknown Unknown
libclik.so 0000152AF020FC33 clik_init Unknown Unknown
libclik_f90.so 0000152AFABAE434 fortran_clik_init Unknown Unknown
libclik_f90.so 0000152AFABB0844 clik_mp_clik_init Unknown Unknown
cosmomc 0000000000513240 Unknown Unknown Unknown
cosmomc 0000000000510A01 Unknown Unknown Unknown
cosmomc 00000000005689C2 Unknown Unknown Unknown
cosmomc 00000000005B22CD Unknown Unknown Unknown
cosmomc 00000000005BBEEC Unknown Unknown Unknown
cosmomc 00000000004109DE Unknown Unknown Unknown
libc-2.17.so 0000152AF22CD3D5 __libc_start_main Unknown Unknown
cosmomc 00000000004108E9 Unknown Unknown Unknown
Primary job terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

Process name: [[61683,1],0]
Exit code: 1

How i can fix this?

Best, Esteban

Luke Hart
Posts: 62
Joined: July 13 2015
Affiliation: University of Manchester

Re: LowTEB likelihood problem

Post by Luke Hart » September 01 2019

Hey Esteban,

Thank you for posting as I had the same problem however I think I cracked it! I went back through my installation and tried recompiling CosmoMC and it said that it required a more updated version of intel. I used 2017 Intel Compilers instead of 2014 Intel Compilers, recompiled CosmoMC and it worked fine.

If you look at Colombo's clik source files, he mentions that it doesn't work with old compilers. So I'd try that if you have older intel compilers.. I'm unsure how gfortran affects this, but it could be that you just need updated compilers..

Hope this helps

Post Reply