Error when trying to change Dark Energy equation of state

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Dournac Fabien
Posts: 7
Joined: May 18 2019
Affiliation: IRAP
Contact:

Error when trying to change Dark Energy equation of state

Post by Dournac Fabien » May 19 2019

Hello,

Into params.ini file of CAMB-1.0.4, I have modified the parameter w initially set to w=-1. I tried by setting : w = -0.96 or w = -1.04

But at the execution, when generating matter power spectrum, I get the following error :

Code: Select all

ERROR STOP Fluid dark energy model does not allow w crossing -1

Error termination. Backtrace:
#0  0x104cc8579
#1  0x104cc9235
#2  0x104cca196
#3  0x104c05130
#4  0x104beac52
#5  0x104c543eb
#6  0x104c5851e
#7  0x104c58e8b
#8  0x104c8357f

About wa parameter, I have already compiled CAMB with "

Code: Select all

make EQUATIONS=equations_ppf
", there is no problem, wa can be varying.

But this doesn't seem to be the same thing for w (actually named w0) since this error above.

Anyone could see what's wrong ? Is there a way to make change this parameter to generate matter power spectrum ?

Regards, Fabien Dournac

Antony Lewis
Posts: 1501
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Error when trying to change Dark Energy equation of state

Post by Antony Lewis » May 20 2019

In version 1.x+ you don't need to change the Makefile options to use different dark energy models. Instead set

Code: Select all

dark_energy_model  = ppf
in the .ini file to use PPF (it should be documented in the sample .ini files in the "inifiles" folder).

Post Reply