Compiling CosmoMC problem

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Hussain Gohar7433
Posts: 2
Joined: December 09 2018
Affiliation: University of Szczecin

Compiling CosmoMC problem

Post by Hussain Gohar7433 » December 09 2018

Hello all,
I was trying to install CosmoMC with Camb on my laptop. I faced a problem when I used the command ''make'' to compile CosmoMC and it showed the attached (below) error. I followed https://arxiv.org/pdf/1808.05080.pdf to understand the whole procedure. I also tried some solutions from the internet but all in vain.
Note: I use ubuntu 18.10 and Intel Fortran compiler.
any one to help?
Regards,
H. Gohar

Code: Select all

mkdir -p ReleaseMPI
cd ../camb && \
make --file=Makefile_main libcamb OUTPUT_DIR=ReleaseMPI \
RECOMBINATION=recfast EQUATIONS=equations_ppf NONLINEAR=halofit_ppf
make[1]: Entering directory '/home/hgohar/CosmoMC/Workplace/CosmoMC-Nov2016/camb'
mkdir -p ReleaseMPI
mpif90 -cpp -O3 -ffast-math -ffree-line-length-none -fopenmp -fmax-errors=4 -march=native -DMPI -DCLIK -JReleaseMPI -IReleaseMPI/ -c constants.f90 -o ReleaseMPI/constants.o
constants.f90:90:29:

         if (id==0) error stop('Error id must be non-zero')
                             1
Error: Blank required in ERROR STOP statement near (1)
make[1]: *** [Makefile_main:131: ReleaseMPI/constants.o] Error 1
make[1]: Leaving directory '/home/hgohar/CosmoMC/Workplace/CosmoMC-Nov2016/camb'
make: *** [Makefile:315: camb] Error 2

Antony Lewis
Posts: 1495
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Compiling CosmoMC problem

Post by Antony Lewis » December 10 2018

Looks like quite an old version, get the latest from github?

Hussain Gohar7433
Posts: 2
Joined: December 09 2018
Affiliation: University of Szczecin

Re: Compiling CosmoMC problem

Post by Hussain Gohar7433 » December 11 2018

Thank you, Antony, for your reply. Yes, I already corrected it from GitHub and it worked without any error.

Post Reply