Dverk error in running CosmoMC

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Hasti Khoraminezhad
Posts: 2
Joined: October 29 2018
Affiliation: SISSA

Dverk error in running CosmoMC

Post by Hasti Khoraminezhad » November 05 2018

Hi
I did some modifications in equations.f90 of the last version of CosmoMC. Then I did the following to add a new parameter "Ome".

(1) In CosmologyType.f90:

I added:
real(mcp) Ome

(2) In CosmologyParameterizations.f90:

I change the number of theory parameters from 16 to 17:
call this%SetTheoryParameterNumbers(17,last_power_index)

Then I added:
CMB%Ome = Params(10)

And change the number of params of the other parameter like this:
CMB%nnu = Params(11)
CMB%YHe =Params(12)
CMB%iso_cdm_correlated = Params(13)
CMB%zre_delta = Params(14)
CMB%ALens = Params(15)
CMB%ALensf = Params(16)
CMB%fdm = Params(17)
Before they were like this:
CMB%nnu = Params(10)
CMB%YHe =Params(11)
CMB%iso_cdm_correlated = Params(12)
CMB%zre_delta = Params(13)
CMB%ALens = Params(14)
CMB%ALensf = Params(15)
CMB%fdm = Params(16)

And also I added it in CMB parameters:
CMB%Ome = Params(7)
and I changed the number of others:
CMB%nnu = Params(8)
it was:
CMB%nnu = Params(7)

(3) In Calculator_CAMB.f90 :
I added:
Ome = CMB%Ome

(4) In params_CMB.paramnames:
I added:
Ome \Omega_{eDE}

(5) In params.ini:
I added:
param[Ome] = 0 -0.00001 0.5 0.0001 0.00001



My params.ini file is like this:

DEFAULT(batch2/plik_dx11dr2_HM_v18_TT.ini)
DEFAULT(batch2/lowTEB.ini)
DEFAULT(batch3/BAO.ini)
DEFAULT(batch2/JLA.ini)
DEFAULT(batch2/H0_prior.ini)

DEFAULT(batch3/common.ini)

MPI_Max_R_ProposeUpdate = 30
propose_matrix= planck_covmats/base_TT_lowTEB_plik.covmat
root_dir = chains/test/
file_root=test
action = 0
test_check_compare = 663.808
num_threads = 0
start_at_bestfit =F
feedback=1
use_fast_slow = T
checkpoint = F
sampling_method = 7
dragging_steps = 3
propose_scale = 2
indep_sample=10
get_sigma8=T
param[w] = -1 -3 1 0.05 0.05
param[Ome] = 0 -0.00001 0.5 0.0001 0.00001


And I didn't change the common.ini file:

batch_name = batch3
local_dir = %LOCALDIR%
data_dir = %LOCALDIR%data/
INCLUDE(likelihood.ini)
INCLUDE(params_CMB_defaults.ini)
include_fixed_parameter_priors = F
feedback = 1
get_sigma8 = T
use_nonlinear_lensing = T
block_semi_fast = F
temperature = 1
samples = 4000000
propose_scale = 1.9
oversample_fast = 1
indep_sample = 10
burn_in = 0
num_threads = 0
MPI_Converge_Stop = 0.01
MPI_StartSliceSampling = F
MPI_Check_Limit_Converge = T
MPI_Limit_Converge = 0.025
MPI_Limit_Converge_Err = 0.2
MPI_LearnPropose = T
MPI_Limit_Param = 0
MPI_R_StopProposeUpdate = 0
MPI_Max_R_ProposeUpdate = 3
MPI_Max_R_ProposeUpdateNew = 50
pivot_k = 0.05
CMB_lensing = T
accuracy_level = 1
high_accuracy_default = T
sampling_method = 7
dragging_steps = 3
use_fast_slow = T
directional_grid_steps = 20
action = 0
estimate_propose_matrix = F
max_like_radius = 0.05
max_like_iterations = 5000
minimization_points_factor = 2
minimize_loglike_tolerance = 0.05
minimize_separate_fast = T
minimize_mcmc_refine_num = 20
minimize_refine_temp = 0.01
minimize_temp_scale_factor = 5
minimize_random_start_pos = T
rand_seed =
checkpoint = T
stop_on_error= T
redo_likelihoods = T
redo_theory = F
redo_cls = F
redo_pk = F
redo_skip = 0
redo_outroot =
redo_thin = 1
redo_add = F
redo_from_text = F
redo_likeoffset = 0



After these modifications I could compile camb and also CosmoMC and there were no error.
It can be run also without error when action = 4 in the params.ini file.
But when I want to run the chains it there is a Dverk error like this:



Number of MPI processes: 1
file_root:test
Random seeds: 23317, 24542 rand_inst: 1
Using clik with likelihood file
./data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik
----
clik version 723c1a4b0580
smica
Checking likelihood './data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik' on test data. got -380.979 expected -380.979 (diff -8.68545e-09)
----
TT from l=0 to l= 2508
Clik will run with the following nuisance parameters:
A_cib_217
cib_index
xi_sz_cib
A_sz
ps_A_100_100
ps_A_143_143
ps_A_143_217
ps_A_217_217
ksz_norm
gal545_A_100
gal545_A_143
gal545_A_143_217
gal545_A_217
calib_100T
calib_217T
A_planck
Using clik with likelihood file
./data/clik/low_l/bflike/lowl_SMW_70_dx11d_2014_10_03_v5c_Ap.clik
BFLike Ntemp = 2876
BFLike Nq = 1407
BFLike Nu = 1407
BFLike Nside = 16
BFLike Nwrite = 32393560
cls file appears to have 5+ columns
assuming it is a CAMB file with l, TT, EE, BB, TE
info = 0
----
clik version 723c1a4b0580
bflike_smw
Checking likelihood './data/clik/low_l/bflike/lowl_SMW_70_dx11d_2014_10_03_v5c_Ap.clik' on test data. got -5247.87 expected -5247.87 (diff 3.85597e-07)
----
TT from l=0 to l= 29
EE from l=0 to l= 29
BB from l=0 to l= 29
TE from l=0 to l= 29
Clik will run with the following nuisance parameters:
A_planck
read jla dataset ./data/jla.dataset
reading BAO data set: 6DF
reading BAO data set: MGS
reading BAO data set: DR12BAO
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: T
TT lmax = 2508
EE lmax = 2500
ET lmax = 2500
BB lmax = 2500
PP lmax = 2500
lmax_computed_cl = 2508
Computing tensors: F
max_eta_k = 14000.00
transfer kmax = 5.000000
adding parameters for: lowl_SMW_70_dx11d_2014_10_03_v5c_Ap
adding parameters for: 6DF
adding parameters for: MGS
adding parameters for: DR12BAO
adding parameters for: HST
adding parameters for: JLA
adding parameters for: plik_dx11dr2_HM_v18_TT
Fast divided into 2 blocks
Block breaks at: 12
25 parameters ( 9 slow ( 0 semi-slow), 16 fast ( 0 semi-fast))
starting Monte-Carlo
CAMB error Dverk error -3 in in GaugeInterface_ScalEv
MpiStop: 0
application called MPI_Abort(MPI_COMM_WORLD, -29901616) - process 0


Would you please let me know that why I have this error?
Thanks in advance.

Antony Lewis
Posts: 1511
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Dverk error in running CosmoMC

Post by Antony Lewis » November 05 2018

Why do you have CMB%Ome = Params(10) and CMB%Ome = Params(7)? You might want to check your CMB spectrum for action=4 to check it agrees with what you export (set test_output_root=path/name to get a dump of the spectra and parameters)

Hasti Khoraminezhad
Posts: 2
Joined: October 29 2018
Affiliation: SISSA

Re: Dverk error in running CosmoMC

Post by Hasti Khoraminezhad » November 05 2018

Thanks for your answer.
but when I did the following the same error occurs:

in the file CosmologyParametrizations.f90 :

in the subroutine SetForH I have:
CMB%Ome = Params(8)

and in the subroutine BK_ParamArrayToTheoryParams I have:
CMB%Ome = Params(8)

with the same number.
And I changed the number of other parameters.

again I can compile it but the same error is happening.
CAMB error Dverk error -3 in GaugeInterface_ScalEv

Post Reply