Page 1 of 1

Problem with running test Plack

Posted: March 01 2018
by Ni Putu Audita P Emas
I am Nimas. I want to ask you about something. I really don't understand about how run test planck. I have trouble:
Number of MPI processes: 1
Random seeds: 27661, 14071 rand_inst: 1
compile with CLIK to use clik - see Makefile
MpiStop: 0
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 128.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
I use cosmoBox to run it.
when I checked forum, but I don't understand how compile it manually (I did set in my environment at .bashrc as instruction on "CosmoMC Installation and Running Guidelines" by Li and Wang but still cannot).

I tried it in my PC (without cosmoBOX) and when I tried to run test planck I get:
STOP Checkpointing without MPI not supported

I had to install openmpi before I compiled cosmoMC but still cannot run this.
that's all about my questions. I am so sorry because I really don't understand. thank you

Re: Problem with running test Plack

Posted: March 02 2018
by Antony Lewis
Make sure the CLIK_PATH environment variable is set; if not, check your clik installation and .bashrc (restart to read .bashrc, or also run common on command line for current session).

The second error sounds as though you need checkpoint=F (but you should run with MPI).

Problem with running test Plack

Posted: April 08 2018
by Ni Putu Audita P Emas
thank you. it worked