CAMB: Accuracy at high l

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Chris D'Andrea
Posts: 2
Joined: June 07 2005
Affiliation: University of Portsmouth

CAMB: Accuracy at high l

Post by Chris D'Andrea » June 07 2005

Hi,
I ran CAMB out to l of 10,000 for a few different cosmological models (yes I know l=10000 is extremely high l but in the next couple of years we will have experiments probing that regime); I first ran it with accuracy_boost and l_accuracy_boost of 1, and then with both at 1.5. The following is a plot of the ratio's of the Cl's for the different accuracy settings. For l > 3,000 the ratio begins to differ significantly from 1. The oscillatory behaviour may not be too worrying because effectively one will use bandpowers, it is the 4% loss of power on small scales that may be a problem. What is the cause of such a large systematic discrepancy? Do you know what accuracy will be needed to give the "right" Cl?
Thank you very much.


~Chris D'Andrea

Image

Antony Lewis
Posts: 1413
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: CAMB: Accuracy at high l

Post by Antony Lewis » June 07 2005

There are lots of things that affect the accuracy on such small scales. Increase the accuracy settings until the result converges.

Of course the unlensed SZ-free power on these scales is extremely small, so the accuracy of the linear result is not likely to be critical for most purposes as it will be swamped by non-linear effects.

Check the k_eta_max_scalar setting, and the the accuracy boost settings up to about 3.

Post Reply