make: *** [~/plancklikelihood/plc-2.0/buildir/clik_example_C] Error 1

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Jian_wei Hu
Posts: 1
Joined: April 11 2013
Affiliation: ITP,CAS

make: *** [~/plancklikelihood/plc-2.0/buildir/clik_example_C

Post by Jian_wei Hu » July 28 2015

Hi, I have a compiling error when I use make install planck-2.0 likelihood.
Here is my makefile:

Code: Select all

CFITSIOPATH := /home/hujianwei/plancklikelihood/plc-1.0
#CFITSIOPATH := /softs/cfitsio/3.24
# you have a CFITSIO lib in a weird location, also set those
CFITSIO_INCPATH := [tex](CFITSIOPATH)/include
CFITSIO_LIBPATH := [/tex](CFITSIOPATH)/lib

#define your compilers and stuff
CC = gcc
FC = ifort


IFORTLIBPATH = /public/software/compiler/intel/composer_xe_2013_sp1.0.080/compiler/lib/intel64
IFORTRUNTIME = -L[tex](IFORTLIBPATH) -lintlc -limf -lsvml -liomp5 -lifport -lifcoremt -lirc -lpthread

MKLROOT = /public/software/compiler/intel/composer_xe_2013_sp1.0.080/mkl
LAPACKLIBPATHMKL = -L[/tex](MKLROOT)/lib/intel64
my cluster installed gcc version is 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC)

and i get a errer as:
build \x1b[36;11m/home/hujianwei/plancklikelihood/plc-2.0/buildir/clik_example_C \x1b[0m
/home/hujianwei/plancklikelihood/plc-2.0/buildir/tmp/clik_example_c.o: In function `main_lensing':
clik_example_c.c:(.text+0x23a): undefined reference to `clik_lensing_get_lmaxs'
collect2: ld returned 1 exit status
make: *** [/home/hujianwei/plancklikelihood/plc-2.0/buildir/clik_example_C] Error 1
I do ask for help from google, but I do not think it give me the useful help.

I will appreciate any help!

Thank you very much!
JW

Daniel Francisco Boriero
Posts: 16
Joined: March 09 2009
Affiliation: Bielefeld

make: *** [~/plancklikelihood/plc-2.0/buildir/clik_example_C

Post by Daniel Francisco Boriero » July 29 2015

Hi Jian,

I would recommend to use the ./waf tool and also change from gcc to icc, so you would be restricted to Intel tools, which give lesser probability to occur errors. I also had to download and install specific versions of libraries used by CLIK, because of this I set the flag " --forceinstall_all_deps", as below:

./waf configure --lapack_mkl=${MKLROOT} --forceinstall_all_deps --ifort --icc --lapack_mkl_version=YOURVERSION


Best
Daniel

Post Reply