New Cosmomc release?

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
gongbo zhao
Posts: 69
Joined: January 04 2005
Affiliation: ICG, Portsmouth
Contact:

New Cosmomc release?

Post by gongbo zhao » July 13 2015

Hi Antony,

Since the new Planck likelihood is released today (http://xxx.lanl.gov/abs/1507.02704), I am wondering when the new CosmoMC will be released?

Thanks,
GB

Antony Lewis
Posts: 1547
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: New Cosmomc release?

Post by Antony Lewis » July 13 2015

I think the paper is released but not yet the likelihood code; hopefully very soon...

Antony Lewis
Posts: 1547
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: New Cosmomc release?

Post by Antony Lewis » July 13 2015

Now available. For CosmoMC see

http://cosmologist.info/cosmomc/readme.html

for download links, or see the GitHub page

https://github.com/cmbant/CosmoMC

for latest fixes.

Let me know if you have any problems with the instructions or usage, there are a large number of changes since the previous release.

bin hu
Posts: 23
Joined: September 18 2008
Affiliation: leiden univ

New Cosmomc release?

Post by bin hu » July 14 2015

The new likelihood looks ask for at least python 2.7+

Antony Lewis
Posts: 1547
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: New Cosmomc release?

Post by Antony Lewis » July 14 2015

Not sure you actually need python for the likelihoods, but certainly would be a good idea to get python 2.7 or 3.4 - all the CosmoMC parameter grid/getdist/gui/plotting code requires them.

bin hu
Posts: 23
Joined: September 18 2008
Affiliation: leiden univ

New Cosmomc release?

Post by bin hu » July 14 2015

waf installation ask for python 2.7+, otherwise, sysconfig module is missing error

Antony Lewis
Posts: 1547
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: New Cosmomc release?

Post by Antony Lewis » July 14 2015

waf is python, but I think you can also install more directly with make (see http://wiki.cosmos.esa.int/planckpla201 ... _and_tools). But you should get python 2.7+ anyway..

Post Reply