COSMOMC: code gets stuck in parameter space

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Sophie Morris
Posts: 1
Joined: June 18 2012
Affiliation: University of Nottingham

COSMOMC: code gets stuck in parameter space

Post by Sophie Morris » August 29 2013


I am running the 2013 Planck version of COSMOMC and have added in my own parameter by reassigning the wa_ppf to my own parameter in CMB_Cls_simple.f90 and then using my own equations module (a modified version of the equations_quint.f90 module).

I have managed to get the code running but after a few hundred steps the code gets stuck on one set of parameter values and cannot move away from this point in parameter space, continuing to take steps that produce no further evolution (so just keeps running over this one point) until I kill the code. It does this every time I run it, but at a different point each time. None of these points are particularly strange and I have even tried to run some of them in CAMB and this handles them fine.

I have also been checking the likelihood values as it runs and these are all reasonable, but the code stops calculating the likelihood around the time it gets stuck so the problem seems to happen before it reaches this point in its process. It is as if the transition probability at that point is 0 so it just stays there, but it seems very strange that it is always a different point.

Does anyone have any ideas as to what could be causing it or a way that I could somehow work around it?


Omar Ruiz Macias
Posts: 10
Joined: February 15 2014
Affiliation: Cinvestav

COSMOMC: code gets stuck in parameter space

Post by Omar Ruiz Macias » September 10 2016

Hi Sophie,

Did you find the problem? I'm trying to do something similar and can not compile a modified version of equations_quint with cosmomc.

Any sugestions would be great.

Post Reply