cosmomc and pgf90 on pentium 4

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Elena Pierpaoli
Posts: 2
Joined: September 25 2004
Affiliation: Caltech

cosmomc and pgf90 on pentium 4

Post by Elena Pierpaoli » December 15 2004

Hi,
does anyone know which flags to use in the compilation of cosmomc with pgf90 on a pentium 4?
Also, which is the correct command to link the lapak library?


Thank you,

Elena

Antony Lewis
Posts: 1413
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: cosmomc and pgf90 on pentium 4

Post by Antony Lewis » December 16 2004

I don't know, but the free GnuF95 compiler works at least for CAMB

http://g95.sourceforge.net/

so you could try that instead if you have problems with pgf90. (please post correct pgf90 settings if you find them out).

Elena Pierpaoli
Posts: 2
Joined: September 25 2004
Affiliation: Caltech

cosmomc and pgf90 on pentium 4

Post by Elena Pierpaoli » December 23 2004

actually, I managed to compile with minimal flags. However, I had troubles because the code coudn't read the input file (quite disappointing indeed!).
There is a problem with iargc function.
I just switched to ifc, and didn't solve the problem with iargc.

Elena

Anze Slosar
Posts: 183
Joined: September 24 2004
Affiliation: Brookhaven National Laboratory
Contact:

Re: cosmomc and pgf90 on pentium 4

Post by Anze Slosar » December 27 2004

Elena Pierpaoli wrote: I just switched to ifc, and didn't solve the problem with iargc.
Well, it works fairly perfectly for me with ifc... Do you use -Vaxlib (I guess, otherwise it wouldn't compile...)?

Alessandro Melchiorri
Posts: 122
Joined: September 24 2004
Affiliation: University of Rome
Contact:

cosmomc and pgf90 on pentium 4

Post by Alessandro Melchiorri » January 20 2005

Ciao Elena,
I managed to succesfully compile it with pgf90 using the fllowing settings:

F90C = pgf90
FFLAGS = -O2
LAPACKL = -L/usr/local/cernlib/other.ports/pgf_lib -lpacklib -llapack3 -lmathlib -lkernlib -lblas
INCLUDE = -I../camb

For pgf90 I also needed to edit a .mypgf90rc file with one line in my home directory:

set GCCDIR=/usr/lib/gcc-lib/i386-redhat-linux/3.2.2;

and now cosmomc works on our farm of P4 processors with RedHat 9.0.

I hope it helps!
Alessandro

Post Reply