cosmomc: seg. fault when additional datasets included

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
moumita aich
Posts: 1
Joined: August 13 2006
Affiliation: iucaa

cosmomc: seg. fault when additional datasets included

Post by moumita aich » June 05 2009

Hi

I have cosmomc compiled on a cluster with

>F90C = f90
>FFLAGS = -omp -O4 -arch host -math_library fast -tune host -fpe1 -lmpi -lfmpi -lrt -pthread -DMPI
>LAPACKL = -L/dsk3/student/moumita/lapack-3.2 -lcxml -lpthread

It runs fine for a single dataset i.e. in the params.ini file, I have
>cmb_numdatasets = 1
>cmb_dataset1 = WMAP

The problem arises when I introduce another dataset i.e. I change the params.ini file as
>cmb_numdatasets = 2
>cmb_dataset1 = WMAP
>cmb_dataset2 = data/acbar2007_v3_corr.newdat

When I try to run cosmomc using the command
>>dmpirun -np 4 -hf host params.ini

The error I get is as follows

Number of MPI processes: 4
Random seeds: 20857, 14741 rand_inst: 1
Reading BCP data set: data/acbar2007_v3_corr.newdat
Reading: acbar2007_v3_corr_
......
......
starting Monte-Carlo
forrtl: severe (174): SIGSEGV, segmentation fault occurred
0: __FINI_00_remove_gp_range [0x3ff81a21488]
1: __FINI_00_remove_gp_range [0x3ff81a2aa84]
2: __FINI_00_remove_gp_range [0x3ff800d9cc0]
3: [tex]calclike[/tex]getloglikepost_ [calclike.f90: 107, 0x1200e6704]
4: [tex]calclike[/tex]getloglike_ [calclike.f90: 84, 0x1200e65b8]
5: [tex]montecarlo[/tex]mcmcsample_ [MCMC.f90: 535, 0x1200f9e98]
6: solvecosmology_ [driver.F90: 327, 0x1200fdb20]
7: main [for_main.c: 203, 0x1200fddcc]
8: __start [0x120038688]
MPI process 3167406 exited with status 174


I have tried doing this on another cluster where this works fine i.e. there was no segmentation fault error but since it is not meant for parallel programs, I cannot run cosmomc on it. But I guess since I can run one chain at a time without any errors, the method for introducing multiple datasets is fine.

I saw cosmocoffee posts regarding this seg. fault error in
http://cosmocoffee.info/viewtopic.php?t=1074
http://cosmocoffee.info/viewtopic.php?t=1274

I have tried 'ulimit -s unlimited' option as in the 1st post but it gives
ulimit: exceeds allowable limit
and so the problem does not get resolved.
Also I guess since cosmomc runs fine for a single dataset, it might not be a problem with lapack as in the 2nd post.

Any help or comments regarding this problem would be appreciated greatly.

Post Reply