error happens when install "wmap likelihood"

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Yongliang Zhao
Posts: 3
Joined: May 26 2009
Affiliation: Purple Mountain Observatory, Chinese Academy of Sciences

error happens when install \"wmap likelihood\"

Post by Yongliang Zhao » May 28 2009

hi
when i am running cosmomc,i install "wmap likelihood".folowing is part of the opitions in the makefile of "likelihood_v3"
#Makefile --- WMAP Likelihood code...

#CFITSIO=/usr/local
CFITSIO=/simdata/meng/liang/cosmomc/source/cfitsio
... ...
## SGI ProPack(Altix)/Intel -- gets the LAPACK functions from the system SCSL library.
F90 = ifort
FFLAGS = -O [tex](WMAPFLAGS)
INCS = -I. -I[/tex](CFITSIO)/include
LIBS = -L. -L$(CFITSIO)/lib -lcfitsio -lscs_mp

after "make"error happens as following:
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o read_archive_map.o read_archive_map.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o read_fits.o read_fits.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o healpix_types.o healpix_types.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o br_mod_dist.o br_mod_dist.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_options.o WMAP_5yr_options.F90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_util.o WMAP_5yr_util.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_gibbs.o WMAP_5yr_gibbs.F90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_tt_pixlike.o WMAP_5yr_tt_pixlike.F90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_tt_beam_ptsrc_chisq.o WMAP_5yr_tt_beam_ptsrc_chisq.f90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_teeebb_pixlike.o WMAP_5yr_teeebb_pixlike.F90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_tetbeebbeb_pixlike.o WMAP_5yr_tetbeebbeb_pixlike.F90
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o WMAP_5yr_likelihood.o WMAP_5yr_likelihood.F90
ar r libwmap5.a read_archive_map.o read_fits.o healpix_types.o br_mod_dist.o WMAP_5yr_options.o WMAP_5yr_util.o WMAP_5yr_gibbs.o WMAP_5yr_tt_pixlike.o WMAP_5yr_tt_beam_ptsrc_chisq.o WMAP_5yr_teeebb_pixlike.o WMAP_5yr_tetbeebbeb_pixlike.o WMAP_5yr_likelihood.o
ar: creating libwmap5.a
ifort -O -DOPTIMIZE -I. -I/simdata/meng/liang/cosmomc/source/cfitsio/include -c -o test.o test.F90
ifort -O -DOPTIMIZE -o test test.o read_archive_map.o read_fits.o healpix_types.o br_mod_dist.o WMAP_5yr_options.o WMAP_5yr_util.o WMAP_5yr_gibbs.o WMAP_5yr_tt_pixlike.o WMAP_5yr_tt_beam_ptsrc_chisq.o WMAP_5yr_teeebb_pixlike.o WMAP_5yr_tetbeebbeb_pixlike.o WMAP_5yr_likelihood.o -L. -L/simdata/meng/liang/cosmomc/source/cfitsio/lib -lcfitsio -lscs_mp
IPO link: can not find -lscs_mp
ifort: error: problem during multi-file optimization compilation (code 1)
make: *** [test] Error 1


when i "make install"in /cosmomc/source/cfitsio,in the /cfitsio/lib,there only exists "libcfitsio.a"and"pkgconfig/cfitsio.pc",there is't "lscs_mp"

could anyone talk me more imformation about the "lscs_mp",could helep me? thanks a lot!

Pascal Vaudrevange
Posts: 50
Joined: March 26 2006
Affiliation: DESY
Contact:

error happens when install \"wmap likelihood\"

Post by Pascal Vaudrevange » May 28 2009

Hi Yongliang,

are you compiling on a computer that has SGI's ProPack installed? scs_mp seems to be the name of the library from that package that contains the LAPACK functions. If you do not have SGI's ProPack,
you should install LAPACK from another source, e.g. Intel's MKL (form http://software.intel.com/en-us/intel-mkl/), from the Lapack website (http://www.netlib.org/lapack/), or as a precompiled package coming from your Linux distribution. You would then need to replace the

Code: Select all

-lscs_mp
by the corresponding libraries and paths, e.g. when using the lapack package from Ubuntu

Code: Select all

-llapack


Pascal

Yongliang Zhao
Posts: 3
Joined: May 26 2009
Affiliation: Purple Mountain Observatory, Chinese Academy of Sciences

error happens when install \"wmap likelihood\"

Post by Yongliang Zhao » June 02 2009

hi Pascal
i changed the makefile:
## CITA Sunnyvale
F90 = ifort
IFFLAGS = -O3 -vec-report0 [tex](WMAPFLAGS)
INCS = -I. -I[/tex](CFITSIO)/include
LIBS = -L. -L$(CFITSIO)/lib -lcfitsio -L/opt/intel/mkl/8.1.1/lib/em64t -lmkl_lapack -lmkl -lpthread[/color]
it's running Successfully,thank you!

Post Reply