COSMOMC : error when running

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Pierre Delsart
Posts: 14
Joined: October 28 2008
Affiliation: tt

COSMOMC : error when running

Post by Pierre Delsart » October 28 2008

Hi,
I'm novice to install COSMOMC. I read the README supplied in the web site and I try to compile COSMOMC. I use WMAP likelihood and I succed to compile.
After that, I compiled successfully camb and the source subdirectory.
So, I tried to run COSMOMC and I obtained this error :
./cosmomc: error while loading shared libraries: libmkl_lapack.so: cannot open shared object file: No such file or directory

In the source subdirectory the makefile is :
F90C = ifort
FFLAGS = -O2 -ip -W0 -WB -openmp -fpp -vec_report0
LAPACKL = -L/opt/intel/mkl/9.1.023/lib/em64t -lmkl_lapack -lmkl -lguide -lpthread


Hence, I tried echo \$LD_LIBRARY_PATH and I obtained :
/opt/intel_fce_80/lib

Finally I read the file .bashrc located in my home directory and there was :
# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc

export LD_LIBRARY_PATH=/opt/intel/mkl/9.1.023/lib/em64t:$LD_LIBRARY_PATH
fi

# User specific aliases and functions


Please can you help me?!!
Thanks a lot

Brian Powell
Posts: 18
Joined: August 08 2006
Affiliation: IPMU, U. of Tokyo

COSMOMC : error when running

Post by Brian Powell » November 14 2008

A quick work around might be to copy your mkl lib file to something like /usr/lib. This directory will most certainly be in your path.

Pascal Vaudrevange
Posts: 50
Joined: March 26 2006
Affiliation: DESY
Contact:

COSMOMC : error when running

Post by Pascal Vaudrevange » November 17 2008

Alternatively, you could try moving the "fi" to the line above "export $LD_LIBRARY_PATH

Post Reply