wmap5 likelihood running error 2

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Susana Landau
Posts: 18
Joined: December 10 2004
Affiliation: Buenos Aires University

wmap5 likelihood running error 2

Post by Susana Landau » March 13 2008

Hi everybody:

when running on a cluster, I had no problems with wmap5 likelihood, however running on my pc, with intel 8.1 fortran compiler and MathkernelLibrary 8.0.2 I get the following running error:

WMAP 5-year likelihood test program
===================================

NOTE: This code uses a different CMB spectrum than previous versions.
The new spectrum (data/test_cls_v3.dat) is a better fit to the data
than the old one (data/test_cls.dat).

As before, a constant offset is now being subtracted from ln(L).
The value of the offset is the sum of the determinant
contributions to ln(L) computed for the CMB spectrum in
data/test_cls_v3.dat, ln_det_C_f:

-2ln(L) = chi^2 + ln_det_C - ln_det_C_f

Reading in Cls from: data/test_cls_v3.dat
Initializing WMAP likelihood, version v3
Segmentation fault


I appreciate much any help anyone can provide with this error

regards

Susana Landau

Akhilesh Nautiyal(akhi)
Posts: 69
Joined: June 13 2007
Affiliation: Malaviya National Institute of Technology Jaipur

wmap5 likelihood running error 2

Post by Akhilesh Nautiyal(akhi) » March 17 2008

Hi,

Apply the change the following two files
WMAP_5yr_teeebb_pixlike.F90
WMAP_5yr_tetbeebbeb_pixlike.F90.

the changes are--
In the declaration of ninvplninv2 chage real to real(8), and change >dble(ninvplninv2) to ninvplninv2 in the arguments of DGEMV.



But still I am getting a large difference as
——-
TOTAL -2ln(L) = 2555.156223
——————————————————————
Expected -2ln(L) = 2658.871392
Difference = -103.715169
——————————————————————

Difference = -103.715169
——————————————————————

I have posted this also in cosmocoffee.

Regards,
Akhilesh

Anze Slosar
Posts: 183
Joined: September 24 2004
Affiliation: Brookhaven National Laboratory
Contact:

wmap5 likelihood running error 2

Post by Anze Slosar » March 17 2008

Susana,

you probably have the same problem as described (and solved) here:
http://cosmocoffee.info/viewtopic.php?t=1074


Akhilesh,

You error is far too big, try linking against a different lapack library (i.e. default linux lapack rather than mkl). If you get the same, you must have broken the code somehow. If you get a different result, then you have a problematic MKL, upgrade to the latest (or a bit older, mkl gets broken often)

Akhilesh Nautiyal(akhi)
Posts: 69
Joined: June 13 2007
Affiliation: Malaviya National Institute of Technology Jaipur

wmap5 likelihood running error 2

Post by Akhilesh Nautiyal(akhi) » March 17 2008

HI,

I have checked it. It is coming when I am using
WMAPFLAGS += -DUSE_HIGHELL_TB
in the Makefile.
Can you please tell me how to solve the problem?

Ragards,
Akhilesh

Susana Landau
Posts: 18
Joined: December 10 2004
Affiliation: Buenos Aires University

wmap5 likelihood running error 2

Post by Susana Landau » March 17 2008

Thank you very much Anze and Akhilesh , the problem is solved

I am sorry Akhilesh, I don't now how to fix yours

Post Reply