instal CAMB

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
moslem zarei
Posts: 28
Joined: March 11 2008
Affiliation: Isfahan University of Technology
Contact:

instal CAMB

Post by moslem zarei » March 11 2008

Hi all

I Run make to compile everything.
But
I could not Run " ./camb params.ini. "

can you help me!

Moslem

Savvas Nesseris
Posts: 70
Joined: April 05 2005
Affiliation: UAM/IFT
Contact:

instal CAMB

Post by Savvas Nesseris » March 11 2008

Some more details would be nice... (System, compiler etc). Also, make sure that "camb" and "params.ini" are in the same working directory as your console (use "pwd" or something like that to make sure) or supply the full path.

PS I assume that you didn't add the dot at the end of " ./camb params.ini . "
as that would obviously create problems.

moslem zarei
Posts: 28
Joined: March 11 2008
Affiliation: Isfahan University of Technology
Contact:

instal CAMB

Post by moslem zarei » March 12 2008

After running ./camb params.ini Ithis error is apeared:

./camb: error while loading shared libraries: libguide.so: cannot open shared object file: No such file or directory

Pascal Vaudrevange
Posts: 50
Joined: March 26 2006
Affiliation: DESY
Contact:

instal CAMB

Post by Pascal Vaudrevange » March 12 2008

A bit more information would be usefull: Are you using windows/ linux/ macos? Which compilers? gcc/ intel?

Check the LD_LIBRARY_PATH. If you are using intel compilers on linux this variable will be adjusted properly by running

Code: Select all

$(PATH_TO_COMPILER)/ifortvars.sh  (if you use bash)
or

Code: Select all

$(PATH_TO_COMPILER)/ifortvars.csh  (if you use tcsh)
where in my case

Code: Select all

$(PATH_TO_COMPILER)=/opt/intel/fce/10.0.023/bin
but this depends on the local installation.

Post Reply