Installing lenspix

Use of Healpix, camb, CLASS, cosmomc, compilers, etc.
Post Reply
Carlos L.A.
Posts: 13
Joined: January 17 2008
Affiliation: ICE

Installing lenspix

Post by Carlos L.A. » February 27 2008

Hi!

I'm trying to install lenspix in a 4 cpu computer, but so far I haven't managed to do it.
Could anyone please tell me how to modify "Makefile" to install it properly? (a Makefile example)
Is mpifortran totally necessary?
What software needs to be installed in the computer? (Healpix, ...)
Does anyone know what's the meaning of this error message: "In file utils.F90:829
Temp%p => Arr(I)%p
1
Error: The upper bound in the last dimension must appear in the reference to the assumed size array 'arr' at (1)."
?

Thanks!

Antony Lewis
Posts: 1503
Joined: September 23 2004
Affiliation: University of Sussex
Contact:

Re: Installing lenspix

Post by Antony Lewis » February 27 2008

The program comes with a sample Makefile. If you want people to help specifically you'll have to give details of what compiler and set up you are using.

You can compile non-MPI.

If it is Gfortran that's giving the utils error, I can send you the latest version which has preprocessor directives to work around the problem on request.

Carlos L.A.
Posts: 13
Joined: January 17 2008
Affiliation: ICE

Installing lenspix

Post by Carlos L.A. » February 27 2008

Yes, it's gfortran that's giving me problems.
Thank you!

Carlos L.A.
Posts: 13
Joined: January 17 2008
Affiliation: ICE

Installing lenspix

Post by Carlos L.A. » March 03 2008

Still having the same problem when compiling lenspix with gfortran.
Anyone got lenspix compiled in a 64bits computer with gfortran? Any problems? Which options did you use?

Post Reply