CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

Problem when running CosmoMC with several threads.
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Tian Qiu



Joined: 01 Jun 2017
Posts: 10
Affiliation: University of Science and Technology of China

PostPosted: April 13 2018  Reply with quote

For CosmoMC, I have set the num_threads such as 8, 24, etc. and it ran well at beginning. However, when it had been going to converge down, for example, R−1 from about 50 to 10 or less, sometimes it would run only with one thread rather than what I had set. But if R−1 remained around a large number and did not go down, it would not happen. Even if I stopped running and restarted the chains with checkpoints, it would happen again.

Since it ran with one thread, it was quite inefficient. I have no idea to deal with the problem.

Thanks advanced.
Back to top
View user's profile [ Hidden ]
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.