CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

Compiling Jan 2017 camb with HyRec
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Tristan L Smith



Joined: 14 Nov 2005
Posts: 14
Affiliation: Swarthmore

PostPosted: July 12 2017  Reply with quote

Hello all,

I am trying to compile HyRec along with the latest (Jan 2017) version of camb (using gfortran) but I keep running into the following error message

Quote:

Undefined symbols for architecture x86_64:
"hyrec_tm_", referenced from:
___recombination_MOD_recombination_tm in hyrec.o
"hyrec_xe_", referenced from:
___recombination_MOD_recombination_xe in hyrec.o
"_rec_build_history_camb_", referenced from:
___recombination_MOD_recombination_init in hyrec.o
ld: symbol(s) not found for architecture x86_64
collect2: error: ld returned 1 exit status


Any suggestions on how to modify the Makefile and/or the linking code would be greatly appreciated!
Back to top
View user's profile [ Hidden ] Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.