CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

use_CMB now set internally from likelihoods
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Rahulkumar Solanki



Joined: 23 Jun 2017
Posts: 2
Affiliation: UTD

PostPosted: June 23 2017  Reply with quote

Hi,
I am following this post to run SNe data alone.
http://cosmocoffee.info/viewtopic.php?t=2135&sid=2624c172a355cdb0bd62226560aae0c8
And I receive following errors.

Number of MPI processes: 1
file_root:test_background
NOTE: use_CMB now set internally from likelihoods
Random seeds: 24273, 409 rand_inst: 1
read jla dataset ./data/jla.dataset
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: T
TT lmax = 2500
EE lmax = 2500
ET lmax = 2500
BB lmax = 2500
PP lmax = 2500
lmax_computed_cl = 2500
Computing tensors: F
max_eta_k = 14000.00
transfer kmax = 5.000000
adding parameters for: JLA
Fast divided into 1 blocks
5 parameters
starting Monte-Carlo
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
Error in halofit
CAMB error
MpiStop: 0
application called MPI_Abort(MPI_COMM_WORLD, 60380640) - process 0

How can I set use_CMB=F inside the likelihood?
Thanks a lot.
Back to top
View user's profile  
Antony Lewis



Joined: 23 Sep 2004
Posts: 1303
Affiliation: University of Sussex

PostPosted: June 23 2017  Reply with quote

Try deleting use_CMB line and add

Code:
use_nonlinear_lensing=F
Back to top
View user's profile [ Hidden ] Visit poster's website
Rahulkumar Solanki



Joined: 23 Jun 2017
Posts: 2
Affiliation: UTD

PostPosted: June 23 2017  Reply with quote

After adding that line, I get following error.
Thanks.

Number of MPI processes: 1
file_root:test_background
Random seeds: 27667, 10429 rand_inst: 1
read jla dataset ./data/jla.dataset
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: F
TT lmax = 2500
EE lmax = 2500
ET lmax = 2500
lmax_computed_cl = 2500
Computing tensors: F
max_eta_k = 6625.000
transfer kmax = 0.8000000
adding parameters for: JLA
Fast divided into 1 blocks
5 parameters
starting Monte-Carlo
Calculator_CAMB: negative Cl (could edit to silent error here)
MpiStop: 0
application called MPI_Abort(MPI_COMM_WORLD, 40452000) - process 0
Back to top
View user's profile  
Antony Lewis



Joined: 23 Sep 2004
Posts: 1303
Affiliation: University of Sussex

PostPosted: June 23 2017  Reply with quote

Not sure, you'll need to figure out why use_CMB is being set to true in Initialize_CMBSettings even though no CMB likelihoods being used.
Back to top
View user's profile [ Hidden ] Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.