CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

Camb: compilling error with "gomp 4.0"
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Marco Xoca



Joined: 23 Oct 2016
Posts: 1
Affiliation: Universidad Autónoma de Baja California

PostPosted: October 23 2016  Reply with quote

Hi, I was trying to run for first time camb (in the jupyter notebook) with the CAMBdemo file. I used this line codes:

Code:

%matplotlib inline
import sys, platform, os
from matplotlib import pyplot as plt
import numpy as np
#uncomment this if you are running remotely and want to keep in synch with repo changes
#if platform.system()!='Windows':
#    !cd $HOME/git/camb; git pull github master; git log -1
print('Using CAMB installed at '+ os.path.realpath(os.path.join(os.getcwd(),'..')))
sys.path.insert(0,os.path.realpath(os.path.join(os.getcwd(),'..')))
import camb
from camb import model, initialpower



But, I got this error:

Code:

Using CAMB installed at /home/xoca/Desktop

---------------------------------------------------------------------------
OSError                                   Traceback (most recent call last)
<ipython-input-1-e5176863e3af> in <module>()
     10 print('Using CAMB installed at '+ os.path.realpath(os.path.join(os.getcwd(),'..')))
     11 sys.path.insert(0,os.path.realpath(os.path.join(os.getcwd(),'..')))
---> 12 import camb
     13 from camb import model, initialpower
     14

/home/xoca/.local/lib/python2.7/site-packages/camb/__init__.py in <module>()
     10 __version__ = "0.1.2"
     11
---> 12 from .baseconfig import dll_import
     13 from .camb import CAMBdata, MatterTransferData, get_results, get_transfer_functions, get_background, \
     14     get_age, get_zre_from_tau, set_z_outputs, set_feedback_level, set_params, get_matter_power_interpolator

/home/xoca/.local/lib/python2.7/site-packages/camb/baseconfig.py in <module>()
     33     if not osp.isfile(CAMBL): sys.exit(
     34         '%s does not exist.\nPlease remove any old installation and install again.' % DLLNAME)
---> 35     camblib = ctypes.LibraryLoader(ifort_gfortran_loader).LoadLibrary(CAMBL)
     36 # camblib = ctypes.cdll.LoadLibrary(CAMBL)
     37 else:

/home/xoca/anaconda2/lib/python2.7/ctypes/__init__.pyc in LoadLibrary(self, name)
    438
    439     def LoadLibrary(self, name):
--> 440         return self._dlltype(name)
    441
    442 cdll = LibraryLoader(CDLL)

/home/xoca/anaconda2/lib/python2.7/ctypes/__init__.pyc in __init__(self, name, mode, handle, use_errno, use_last_error)
    360
    361         if handle is None:
--> 362             self._handle = _dlopen(self._name, mode)
    363         else:
    364             self._handle = handle

OSError: /home/xoca/anaconda2/bin/../lib/libgomp.so.1: version `GOMP_4.0' not found (required by /home/xoca/.local/lib/python2.7/site-packages/camb/camblib.so)



So, can anyone help me with this error please? I really don't understand what is happening.
Back to top
View user's profile [ Hidden ]
Antony Lewis



Joined: 23 Sep 2004
Posts: 1221
Affiliation: University of Sussex

PostPosted: October 24 2016  Reply with quote

Check you have a consistent and up-to-date gcc installation.
Back to top
View user's profile [ Hidden ] Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.