CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

How to include BKP likelihood in Cosmomc?
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Jack Sparrow



Joined: 12 May 2016
Posts: 14
Affiliation: HK

PostPosted: May 18 2016  Reply with quote

Hi, all. I have a question about BKP likelihood. I am trying to constrain the tensor amplitude in my model. I find a very strange thing. When I include all Planck likelihood (all the four likelihoods of Planck) AND the BKP likelihood, the tensor amplitude has a non-zero preferred value. This is not reasonable and I think all the model should prefer a zero tensor amplitude currently. When I include Planck likelihood OR BKP likelihood separately, the result is reasonable and a zero value tensor amplitude is more preferred. So, why a non-zero value is preferred when I combine Planck and BKP? Is there a conflict between them? Or are there non trivial settings in the .ini file? BTW, does the covmat matter in the settings?

Thanks a lot! Can some experienced persons explain it or give me some instructions? Thanks again.
Back to top
View user's profile  
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 34
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 11 2017  Reply with quote

Dear Jack,

first of all, what do you mean that you are including all four Planck likelihoods? Do you mean plik_dx11dr2_HM_v18_TT.ini , plik_dx11dr2_HM_v18_TTTEEE.ini , lowTEB.ini , and lowl.ini? If this is the case, that would be incorrect since you would be double-counting information, I believe you should only add two of these at a time, e.g. for what Planck calls PlanckTT+lowP, you would add plik_dx11dr2_HM_v18_TT.ini and lowTEB.ini, etc. This is the first point.

Second, I don't think a (small) preference for a non-zero tensor-to-scalar ratio is a big problem. As long as it is preferred at only say 1 sigma or so, I think that's not a huge problem.

Finally, in your distparams.ini, did you set limits[r] = 0 N? Because if you didn't do so, that would easily explain your error. You must do this for any parameter for which the prior cuts at a value where the posterior is non-negligible, and the tensor-to-scalar ratio is an example of these. Please see th CosmoMC README for more information.

Cheers,
Sunny
Back to top
View user's profile  
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 34
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 11 2017  Reply with quote

I would also suggest having a read at batch2/BK14_README.txt
Back to top
View user's profile  
Shouvik Roychoudhury



Joined: 14 Aug 2016
Posts: 20
Affiliation: Harish-Chandra Research Institute

PostPosted: April 14 2017  Reply with quote

Doesn't the Nov 2016 version of CosmoMC automatically add the limits[r] = 0 N? (In the .derived_ranges files (in /paramnames folder), see Version History section)
Back to top
View user's profile  
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 34
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 14 2017  Reply with quote

Yes it should
Back to top
View user's profile  
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 34
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 14 2017  Reply with quote

The default distparams.ini I believe also has this setting
Back to top
View user's profile  
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.