CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

iCosmo: Galaxy redshift distribution
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> iCosmo
View previous topic :: View next topic  
Author Message
Charles Shapiro



Joined: 05 Feb 2005
Posts: 24
Affiliation: University of Portsmouth

PostPosted: February 22 2009  Reply with quote

Hello,

Can someone please explain how to generate lensing Cls using my own galaxy redshift distribution, p(z) ? It's not clear to me from the help messages.

Thanks a lot,
Chaz
Back to top
View user's profile [ Hidden ]
Charles Shapiro



Joined: 05 Feb 2005
Posts: 24
Affiliation: University of Portsmouth

PostPosted: February 22 2009  Reply with quote

Actually I'm having a little trouble using the preset parameters, too. If I specify

Code:
fid=set_fiducial(expt_in={sv1_n_zbin:1,sv1_dndzp:[1.,4.]})
sv=mk_survey(fid,'sv1')

then I get a whole bunch of these:
Code:
% Program caused arithmetic error: Floating underflow


So it would be helpful to see some examples of the right way to set the galaxy distribution.

Thanks,
Chaz
Back to top
View user's profile [ Hidden ]
Charles Shapiro



Joined: 05 Feb 2005
Posts: 24
Affiliation: University of Portsmouth

PostPosted: February 23 2009  Reply with quote

Ok, despite the (many!) warning messages, the Smail parameter inputs do seem to work.

However, when I specify a median redshift e.g.
Code:
expt_in={sv1_z_med:1.1}

this input gets ignored. I've traced the problem to the "expt_" functions such as expt_generic.pro and expt_snap.pro. In these files, I find

Code:
if tag_check(expt_in,'sv1_z_med',val=val) then sv1_z_m=val


where the variable sv1_z_m seems like it should be sv1_z_med. Likewise for sv2, sv3.

Chaz
Back to top
View user's profile [ Hidden ]
Ivan Debono



Joined: 17 Apr 2007
Posts: 25
Affiliation: APC, Paris 7 / OBSPM

PostPosted: February 24 2009  Reply with quote

There's a bug in the expt routines. The output variable should be sv1_zmed, sv2_zmed, etc.
Back to top
View user's profile  
Anais Rassat



Joined: 20 Oct 2004
Posts: 30
Affiliation: LASTRO (EPFL)

PostPosted: March 04 2009  Reply with quote

Hi,

Here is a link from djfanning's IDL website about getting rid of over/under flow errors in IDL.

http://www.dfanning.com/math_tips/underflow.html

There is indeed a bug in the expt_generic.pro routine, which will be corrected in the next version of iCosmo. In the meantime you can replace the following lines:
Code:

if tag_check(expt_in, 'sv1_z_med', val=val) then sv1_z_m=val

by
Code:
if tag_check(expt_in, 'sv1_z_med', val=val) then sv1_z_med=val

and do this for lines corresponding to survey1, survey2 and survey3.
Anais.
Back to top
View user's profile [ Hidden ] Visit poster's website
Charles Shapiro



Joined: 05 Feb 2005
Posts: 24
Affiliation: University of Portsmouth

PostPosted: May 10 2010  Reply with quote

Looks like this never got answered...

What is the correct way to call mk_survey() in order to specify my own tabulated galaxy distribution, p(z)?

Thanks,
Chaz
Back to top
View user's profile [ Hidden ]
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> iCosmo All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.