CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

Building Planck likelihood
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 05 2017  Reply with quote

I am getting the following error when I run test_planck.ini

Number of MPI processes: 1
file_root:test
Random seeds: 17138, 20248 rand_inst: 1
Using clik with likelihood file
./data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik
clik_init(../src/clik.c:57)::ForwardError
cldf_open(../src/cldf/cldf.c:191)::ForwardError
cldf_open_sub(../src/cldf/cldf.c:108)::Error −1234 (cannot stat file (error −1))
——————————————————-
Primary job terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
——————————————————-
————————————————————————–
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

Process name: [[53428,1],0]
Exit code: 46
————————————————————————–
Thanks in advance.....
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1277
Affiliation: University of Sussex

PostPosted: April 06 2017  Reply with quote

Did you make symlink OK so ./data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik does actually exist?
Back to top
View user's profile [ Hidden ] Visit poster's website
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 39
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 06 2017  Reply with quote

Looks like you might not have linked the Planck likelihood properly. First of all, did you install the Planck likelihood (basically, plc_2.0)? Next, did you link it correctly in your .ini files? For example, if I open my .ini file batch2/plik_dx11dr2_HM_v18_TT.ini, the last line reads:
clik_data_plik = /global/homes/v/vagnox92/Planck/data/plc_2.0/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik
Make sure you also linked your Planck likelihood correctly, assuming you have installed it.
Back to top
View user's profile  
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 06 2017  Reply with quote

Ty so much It is running now but I am encountering a new error.Please help


purnalingam@IDL:~/workspace/CosmoMC-Nov2016$ mpirun -np 1 ./cosmomc test_planck.ini
Number of MPI processes: 1
file_root:test
Random seeds: 30574, 9385 rand_inst: 1
Using clik with likelihood file
./data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik
—-
clik version 6dc2a8cf3965
smica
Checking likelihood './data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik' on test data. got −380.979 expected −380.979 (diff −8.68135e−09)
—-
TT from l=0 to l= 2508
Clik will run with the following nuisance parameters:
Acib_217
cib_index
xi_sz_cib
Asz
ps_A100_100
ps_A143_143
ps_A143_217
ps_A217_217
ksz_norm
gal545_A100
gal545_A143
gal545_A143_217
gal545_A217
calib_100T
calib_217T
Aplanck
Using clik with likelihood file
./data/clik/low_l/commander/commander_rc2_v1.1_l2_29_B.clik
—-
clik version 6dc2a8cf3965
gibbs_gauss 1478fb2d−28fa−49ac-a8ae−677dbdc3600a
Checking likelihood './data/clik/low_l/commander/commander_rc2_v1.1_l2_29_B.clik' on test data. got −7.32304 expected −7.32304 (diff −2.52096e−10)
—-
TT from l=0 to l= 29
Clik will run with the following nuisance parameters:
Aplanck
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: T
TT lmax = 2508
EE lmax = 2500
ET lmax = 2500
BB lmax = 2500
PP lmax = 2500
lmax_computed_cl = 2508
Computing tensors: F
max_eta_k = 14000.00
transfer kmax = 5.000000
adding parameters for: smica_g30_ftl_full_pp
adding parameters for: BKPlanck_detset_comb_dust
adding parameters for: commander_rc2_v1.1_l2_29_B
adding parameters for: plik_dx11dr2_HM_v18_TT
Fast divided into 1 blocks
22 parameters ( 8 slow ( 0 semi-slow), 14 fast ( 0 semi-fast))
Time for theory: 2.60129
Time for smica_g30_ftl_full_pp: 1.122732646763325E−004
Time for BKPlanck_detset_comb_dust: 2.658066805452108E−004
Time for commander_rc2_v1.1_l2_29_B: 4.227529279887676E−005
Time for plik_dx11dr2_HM_v18_TT: 1.119635067880154E−002
loglike chi-sq
21.932 43.864 CMB: BKPLANCK = BKPlanck_detset_comb_dust
15.348 30.696 CMB: lensing = smica_g30_ftl_full_pp
634.530 1269.060 CMB: plik = plik_dx11dr2_HM_v18_TT
9.002 18.005 CMB: lowl = commander_rc2_v1.1_l2_29_B
Test likelihoods done, total logLike, chi-eq = 680.937 1361.875
Expected likelihoods, total logLike, chi-eq = 5859.141 11718.282
** Likelihoods do not match **
MpiStop: 0
————————————————————————–
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 256.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
————————————————————————–
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1277
Affiliation: University of Sussex

PostPosted: April 06 2017  Reply with quote

If you've changed from the default lowTEB likelihood in test_planck.ini, you can't expect the likelihoods to still match the test value.
Back to top
View user's profile [ Hidden ] Visit poster's website
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 06 2017  Reply with quote

oh ok ty sir but the same error persists when I run the default test.ini .Please look at the following results.

purnalingam@IDL:~/workspace/CosmoMC-Nov2016$ mpirun -np 1 ./cosmomc test.ini
Number of MPI processes: 1
file_root:test
Random seeds: 9548, 22300 rand_inst: 1
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: T
TT lmax = 2500
EE lmax = 2500
ET lmax = 2500
BB lmax = 2500
PP lmax = 2500
lmax_computed_cl = 2500
Computing tensors: F
max_eta_k = 14000.00
transfer kmax = 5.000000
adding parameters for: smica_g30_ftl_full_pp
adding parameters for: BKPlanck_detset_comb_dust
Fast divided into 2 blocks
Block breaks at: 7
8 parameters ( 5 slow ( 0 semi-slow), 3 fast ( 0 semi-fast))
skipped unused params: acib217 xi asz143 aps100 aps143 aps143217 aps217 aksz kgal100 kgal143 kgal143217 kgal217 cal0 cal2
Time for theory: 2.68714
Time for smica_g30_ftl_full_pp: 1.212891656905413E−004
Time for BKPlanck_detset_comb_dust: 2.706903032958508E−004
loglike chi-sq
21.932 43.864 CMB: BKPLANCK = BKPlanck_detset_comb_dust
15.349 30.698 CMB: lensing = smica_g30_ftl_full_pp
Test likelihoods done, total logLike, chi-eq = 37.281 74.562
Expected likelihoods, total logLike, chi-eq = 28.337 56.674
** Likelihoods do not match **
MpiStop: 0
————————————————————————–
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 256.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
————————————————————————–
Back to top
View user's profile [ Hidden ] Visit poster's website
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 06 2017  Reply with quote

This is what I am getting when I run default test_planck.ini sir.Please help.


purnalingam@IDL:~/workspace/CosmoMC-Nov2016$ mpirun -np 1 ./cosmomc test_planck.ini
Number of MPI processes: 1
file_root:test
Random seeds: 7996, 12392 rand_inst: 1
Using clik with likelihood file
./data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik
—-
clik version 6dc2a8cf3965
smica
Checking likelihood './data/clik/hi_l/plik/plik_dx11dr2_HM_v18_TT.clik' on test data. got −380.979 expected −380.979 (diff −8.68135e−09)
—-
TT from l=0 to l= 2508
Clik will run with the following nuisance parameters:
Acib_217
cib_index
xi_sz_cib
Asz
ps_A100_100
ps_A143_143
ps_A143_217
ps_A217_217
ksz_norm
gal545_A100
gal545_A143
gal545_A143_217
gal545_A217
calib_100T
calib_217T
Aplanck
Using clik with likelihood file
./data/clik/low_l/bflike/lowl_SMW_70_dx11d_2014_10_03_v5cAp.clik
BFLike Ntemp = 2876
BFLike Nq = 1407
BFLike Nu = 1407
BFLike Nside = 16
BFLike Nwrite = 32393560
cls file appears to have 5+ columns
assuming it is a CAMB file with l, TT, EE, BB, TE
info = 0
—-
clik version 6dc2a8cf3965
bflike_smw
Checking likelihood './data/clik/low_l/bflike/lowl_SMW_70_dx11d_2014_10_03_v5cAp.clik' on test data. got −5247.87 expected −5247.87 (diff 3.93629e−07)
—-
TT from l=0 to l= 29
EE from l=0 to l= 29
BB from l=0 to l= 29
TE from l=0 to l= 29
Clik will run with the following nuisance parameters:
Aplanck
Doing non-linear Pk: F
Doing CMB lensing: T
Doing non-linear lensing: T
TT lmax = 2508
EE lmax = 2500
ET lmax = 2500
BB lmax = 2500
PP lmax = 2500
lmax_computed_cl = 2508
Computing tensors: F
max_eta_k = 14000.00
transfer kmax = 5.000000
adding parameters for: lowl_SMW_70_dx11d_2014_10_03_v5cAp
adding parameters for: smica_g30_ftl_full_pp
adding parameters for: BKPlanck_detset_comb_dust
adding parameters for: plik_dx11dr2_HM_v18_TT
Fast divided into 1 blocks
22 parameters ( 8 slow ( 0 semi-slow), 14 fast ( 0 semi-fast))
Time for theory: 2.85964
Time for lowl_SMW_70_dx11d_2014_10_03_v5cAp: 0.500910742674023
Time for smica_g30_ftl_full_pp: 1.108569558709860E−004
Time for BKPlanck_detset_comb_dust: 2.647771034389734E−004
Time for plik_dx11dr2_HM_v18_TT: 1.520338072441518E−002
loglike chi-sq
21.932 43.864 CMB: BKPLANCK = BKPlanck_detset_comb_dust
15.348 30.696 CMB: lensing = smica_g30_ftl_full_pp
634.530 1269.060 CMB: plik = plik_dx11dr2_HM_v18_TT
5250.022 10500.044 CMB: lowTEB = lowl_SMW_70_dx11d_2014_10_03_v5cAp
Test likelihoods done, total logLike, chi-eq = 5921.957 11843.914
Expected likelihoods, total logLike, chi-eq = 5859.141 11718.282
** Likelihoods do not match **
MpiStop: 0
————————————————————————–
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 256.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
————————————————————————–
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1277
Affiliation: University of Sussex

PostPosted: April 07 2017  Reply with quote

Sure you didn't change any other parameters in the .ini files (or included ones?). Check with a clean checkout of cosmomc if in doubt.
Back to top
View user's profile [ Hidden ] Visit poster's website
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 07 2017  Reply with quote

Sir, Actually I am running both cases.

1. without any additional parameters(the default code).

2. with 3 new theory parameters

I am getting the same mismatch in the likelihoods.If I have new parameters, should I ignore this error and continue with action = 0.

Thanks in advance.
Back to top
View user's profile [ Hidden ] Visit poster's website
Sunny Vagnozzi



Joined: 15 Aug 2016
Posts: 39
Affiliation: Oskar Klein Centre, Stockholm University

PostPosted: April 07 2017  Reply with quote

Could you please post your .ini file for the first case here (without any additional parameters)? I would just like to double-check and make sure you didn't inadvertently change something.
Back to top
View user's profile  
Luke Hart



Joined: 13 Jul 2015
Posts: 25
Affiliation: University of Manchester

PostPosted: April 07 2017  Reply with quote

Just as a tip for debugging, if you are running CosmoMC in likelihood mode you needn't check it on MPI. The MPI will try and run lots of different processes, all just checking the likelihood. If you're using action = 4 you can just run it for the console.

As an aside question @Sunny and @Antony, should the test likelihood be identical to the expected likelihood? I think I might have checked and when it was close enough I just thought, well that's okay and carried on. Should I have configured them for indistinguishability??

Luke
Back to top
View user's profile  
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 07 2017  Reply with quote

Sorry for all the trouble I have once change tau value to 0.07 as it was giving error.That is is the cause of the likelihood mismatch.

ty so much.

but one more clarification.

I am adding 3 more theory parameters, by running with action = 4 I get the error likelihoods doesn't match.I have to confirm that can I start running action = 0 for my modified code?

thanks in advance.
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1277
Affiliation: University of Sussex

PostPosted: April 07 2017  Reply with quote

The test files should run with "OK" result if the input files are unmodified, or any new parameter central values are set such that they have no impact on CAMB's theoretical predictions for the default model.
Back to top
View user's profile [ Hidden ] Visit poster's website
R Purnalingam



Joined: 03 Mar 2017
Posts: 19
Affiliation: IIT KANPUR

PostPosted: April 08 2017  Reply with quote

Ty so much sir, it is up and running.
Back to top
View user's profile [ Hidden ] Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.