CosmoCoffee Forum Index CosmoCoffee

 
 FAQFAQ   SearchSearch  MemberlistSmartFeed   MemberlistMemberlist    RegisterRegister 
   ProfileProfile   Log inLog in 
Arxiv New Filter | Bookmarks & clubs | Arxiv ref/author:

Problem when running test.ini
 
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software
View previous topic :: View next topic  
Author Message
Francesco Capozzi



Joined: 30 Mar 2013
Posts: 1
Affiliation: INFN -Bari

PostPosted: April 04 2013  Reply with quote

Hello,

this is the first time I use cosmomc. I installed planck likelihood following the instructions given in the readme. I compiled cosmomc using the makefile and there were no errors during compilation. However when I try to run cosmomc with test.ini the program stops without even starting:



francesco@Francesco:~/Scrivania/monte_carlo/cosmomc$ ./cosmomc test.ini
Number of MPI processes: 1
Random seeds: 15263, 7199 rand_inst: 1
compile with CLIK to use clik - see Makefile
MpiStop: 0
————————————————————————–
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 0.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.




I do not know why this is happening, but it seems the problem is related to MPI. Can anyone help me, please?
Back to top
View user's profile  
Antony Lewis



Joined: 23 Sep 2004
Posts: 1257
Affiliation: University of Sussex

PostPosted: April 04 2013  Reply with quote

Did you set up your environment variables and log out and in again before compiling, as described at

http://cosmologist.info/cosmomc/readme_planck.html

? i.e. check that

Code:
echo $PLANCKLIKE

gives you the right output ("cliklike").
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1257
Affiliation: University of Sussex

PostPosted: April 04 2013  Reply with quote

Try manually setting PLANCKLIKE in the source makefile, clean and make.

[sorry something went wrong with posting there, intermediate message deleted]
Back to top
View user's profile [ Hidden ] Visit poster's website
Akhilesh Nautiyal(akhi)



Joined: 13 Jun 2007
Posts: 58
Affiliation: Malaviya National Institute of Technology Jaipur

PostPosted: April 04 2013  Reply with quote

HI,

I also tried to run cosmomc with new PLanck likelihood code. It got compiled but doesn't start. when I try to run with test.ini, it gives the following error message.

MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: Cluster collective optimizations enabled.
MPI Environmental Settings
MPI: MPI_MEMMAP_OFF (default: 0) : 1
MPI: MPI_VERBOSE (default: 0) : 1
MPI: Using the InfiniBand interconnect.
Number of MPI processes: 64
Error creatinging or opening chains/test_33.log
MpiStop: 32
MPI: Global rank 32 is aborting with error code −706604.
Process ID: 3603, Host: r3i1n14, Program: /home/akhileshn/planck_era/cosmomc/cosmomc

MPI: ——–stack traceback——-
Error creatinging or opening chains/test_1.log
MpiStop: 0
MPI: Global rank 0 is aborting with error code −706604.
Process ID: 3637, Host: r3i1n14, Program: /home/akhileshn/planck_era/cosmomc/cosmomc
Can any one let me know what to do.

Regards,
akhielsh
Back to top
View user's profile [ Hidden ]
Sheng Li



Joined: 26 May 2009
Posts: 57
Affiliation: University of Sussex

PostPosted: April 04 2013  Reply with quote

Akhilesh Nautiyal(akhi) wrote:
HI,

I also tried to run cosmomc with new PLanck likelihood code. It got compiled but doesn't start. when I try to run with test.ini, it gives the following error message.

MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: libmpi.so 'SGI MPT 2.05 10/20/11 05:35:28'
MPI: Cluster collective optimizations enabled.
MPI Environmental Settings
MPI: MPI_MEMMAP_OFF (default: 0) : 1
MPI: MPI_VERBOSE (default: 0) : 1
MPI: Using the InfiniBand interconnect.
Number of MPI processes: 64
Error creatinging or opening chains/test_33.log
MpiStop: 32
MPI: Global rank 32 is aborting with error code −706604.
Process ID: 3603, Host: r3i1n14, Program: /home/akhileshn/planck_era/cosmomc/cosmomc

MPI: ——–stack traceback——-
Error creatinging or opening chains/test_1.log
MpiStop: 0
MPI: Global rank 0 is aborting with error code −706604.
Process ID: 3637, Host: r3i1n14, Program: /home/akhileshn/planck_era/cosmomc/cosmomc
Can any one let me know what to do.

Regards,
akhielsh


mkdir chains under your cosmomc foler, plz.
Back to top
View user's profile [ Hidden ] Visit poster's website
Antony Lewis



Joined: 23 Sep 2004
Posts: 1257
Affiliation: University of Sussex

PostPosted: April 04 2013  Reply with quote

64 is usually far too many chains. Use 4−8.
Back to top
View user's profile [ Hidden ] Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    CosmoCoffee Forum Index -> Computers and software All times are GMT + 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group. Sponsored by WordWeb online dictionary and dictionary software.